FP: FrontPage Appears to Hang When You Use Dial-Up-Adapter

Last reviewed: March 18, 1998
Article ID: Q153685

The information in this article applies to:
  • Microsoft FrontPage 98 for Windows
  • Microsoft FrontPage 97 for Windows with Bonus Pack
  • Microsoft FrontPage for Windows, version 1.1

SYMPTOMS

When you use a Dial-Up-Adapter to connect to the Internet and you are not currently connected, your computer may appear to hang (stop responding) when you use FrontPage Explorer or FrontPage TCP/IP Test.

CAUSE

If you are using DNS for name resolution, any call to the TCP/IP stack will attempt to resolve to an IP address. If you are not connected to your Internet service provider, there is no DNS server available. The computer will attempt to wait until a DNS server replies.

WORKAROUND

To work around this problem, use the following steps:

  1. Find the Hosts file (located in the C:\Windows\ folder). If it does not exist, rename Hosts.sam to Hosts.

  2. Open the Hosts file in a text editor (such as Notepad), and add the following line to the end of the file

          127.0.0.1       <fqdn>
    
       where <fqdn> is the Fully Qualified Domain Name as specified on the
       DNS Configuration tab of the TCP/IP Properties tab (double-click
       the Network icon in Windows Control Panel). For example, if the Host is
       named Mycomputer and the Domain is called Mynetwork.com, you would add
       the following line to the Hosts file:
    
          127.0.0.1       mycomputer.mynetwork.com
    


Additional query words: Front Page 1.10 lock up freeze crash
Keywords : kbnetwork kbdta
Version : windows:1.1,97,98
Platform : WINDOWS
Hardware : x86
Issue type : kbprb


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 18, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.