FP: General File Transfer Error -3 Installing FrontPage

Last reviewed: March 18, 1998
Article ID: Q163665
The information in this article applies to:
  • Microsoft FrontPage 98 for Windows
  • Microsoft FrontPage 97 for Windows with Bonus Pack

SYMPTOMS

When you install Microsoft FrontPage on a computer that is running a shared network installation of Microsoft Office 7.0, Microsoft Excel 7.0, Microsoft Word 7.0, or Microsoft PowerPoint 7.0, you may receive one of the following error messages:

   Severe: General File Transfer Error -3.
   Please check your target location and try again

-or-

   General file transfer error.  Please check your target location and try
   again.

   Error Number: -3

CAUSE

These error messages may appear in either of the following cases:

Case 1:   You do not have write privileges to the network share that
          contains the Office 95 shared components. Microsoft FrontPage
          shares text converters and proofing tools with Microsoft Office
          applications. During installation, FrontPage setup attempts to
          upgrade some of these shared components. If the Setup program
          cannot upgrade these components, you will receive the first
          error message.

Case 2:   FrontPage 98 cannot install to the root directory of any hard
          disk. If FrontPage 97 was installed in the root directory of
          your hard disk, the FrontPage 98 Setup program will attempt to
          upgrade the files in the root directory.

RESOLUTION

Use one of the following methods to install FrontPage 98:

Case 1: If You Do not Have Write Privileges to the Network Share

From any workstation that uses the shared components on the network server, grant write permissions to the network server, and then run FrontPage Setup one time. After the Setup program has completed and the shared components are upgraded, you can run subsequent installations without setting write permissions to the shared network server.

NOTE: This error does not occur with shared installations of Office 97 because the shared components in Office 97 do not need to be upgraded by FrontPage Setup.

For additional information, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q160833
   TITLE     : FP: How FrontPage Handles Document Conversion to HTML

   ARTICLE-ID: Q160226
   TITLE     : FP: Can't Use Proofing Tools or Text Converters

Case 2: If FrontPage Is Installed in the Root Directory

  1. On the Windows Start menu, point to Settings, and then click Control Panel.

  2. Double-click the Add/Remove Programs icon.

    NOTE: If you attempted to upgrade a FrontPage 97 installation, you may see both FrontPage 97 and FrontPage 98 in the list of installed programs.

  3. Uninstall FrontPage.

    - In the list of installed programs, select Microsoft FrontPage 97 and

         then click Add/Remove.
    

         -and/or-
    

    - In the list of installed programs, select Microsoft FrontPage 98 and

         then click Add/Remove.
    

  4. Start the FrontPage 98 setup program.

    NOTE: If you are upgrading from FrontPage 97, use the following steps. If you are not upgrading from FrontPage 97, go to step 5.

        a. When you are prompted to enter the CD key, enter this number and
           then click Continue.
    

        b. If you receive a message indicating that the upgrade check
           failed, click Locate.
    

        c. Remove the FrontPage 98 compact disc from the CD-ROM drive
           and replace it with the FrontPage 97 compact disc.
    

           NOTE: If the Microsoft FrontPage 97 with Bonus Pack screen
           appears, close it.
    

        d. In the Locate Directory dialog box, select your CD-ROM drive.
           Click OK.
    

        e. When the Setup Type screen appears, remove the FrontPage 97
           compact disc and replace it with the FrontPage 98 compact disc.
    

           NOTE: If the Microsoft FrontPage 98 installation screen appears,
           close it.
    

  5. Select a destination directory other than the root directory. To do this, click Browse when you are prompted to select the Destination Directory. For example, select the C:\Program Files \Microsoft FrontPage directory. If you receive a message asking you if you want to create this directory, click Yes.

  6. Follow the instructions on your screen.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.


Additional query words: 97 98 2.0 NT -3
Keywords : kberrmsg kbinterop kbnetwork kbsetup kbdta
Version : windows:97,98
Platform : WINDOWS
Hardware : x86
Issue type : kbprb


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Last reviewed: March 18, 1998
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