The information in this article applies to:
- Microsoft Internet Explorer versions 2.0, 3.0 for Windows 95
SYMPTOMS
When you try to use Internet Explorer to connect to a World Wide Web site
after a connection to the Internet has been established, you may receive
one of the following error messages:
- Could not open http://<site>.
- The Internet site <site> was not found. Please make sure the address
is correct. Could not open http://<site>.
<Site> is the domain name of the site you are trying access.
CAUSE
These errors can occur for any of the following reasons:
- Transmission Control Protocol/Internet Protocol (TCP/IP) is not properly
configured to use a Domain Name Server (DNS).
- The Web site you are attempting to connect to is outside the domain of
your Internet service provider (ISP), and TCP/IP is not properly
configured to use a default gateway when accessing a remote network.
- The Web site you are trying to connect to is not available.
- One or more global TCP/IP setting conflicts with the TCP/IP settings
for the connection used to connect to your ISP.
- Internet Explorer is configured to connect to the Internet by using both
Dial-Up Networking and a proxy server (a server on a local area network
that lets you connect to the Internet without using a modem). With
versions of Internet Explorer earlier than version 3.0, this behavior
occurs when both the Use AutoDial and Use Proxy Server options in the
Internet Properties dialog box are enabled. With Internet Explorer 3.0,
this occurs when both the Connect To The Internet As Needed and Connect
Through A Proxy Server options in the Internet Properties dialog box are
enabled.
- The Wsock32.dll file included with Windows 95 has been replaced by a
third-party program.
- Internet Explorer's cache is too full, or one or more of the files
stored in the cache is damaged.
- One or more TCP/IP components are not functioning properly.
RESOLUTION
To work around this problem, use the PING command to determine if the
problem is being caused by incorrect default gateway settings or incorrect
DNS server settings. To do this, click Start, point to Programs, click
Command Prompt, and type the following commands at the command prompt
(press ENTER after each command)
cd \<windows>
ping <site>
where <windows> is the name of the folder in which you installed Windows
and <site> is the name of the domain you are trying to access.
If a "Bad IP Address" error message is displayed, the error is likely being
caused by incorrect DNS server settings. To work around this problem, see
the "DNS Server Settings" section in this article.
If a "Reply from <xxx.xxx.xxx.xxx>: Destination net unreachable" error
message is displayed (where <xxx.xxx.xxx.xxx> is the IP address of the
site you are attempting to connect to), the error is likely being caused
by incorrect default gateway settings. To work around this problem, see
the "Default Gateway Settings" section in this article.
If the steps in the "DNS Server Settings" or "Default Gateway Settings"
section in this article do not resolve the problem, see the "Additional
Troubleshooting Steps" section in this article.
DNS Server Settings
If you are accessing the Internet using Dial-Up Networking, use the
following steps:
- Click Start, point to Programs, point to Accessories, and then click
Dial-Up Networking.
- Use the right mouse button to click the connection used to connect to
your ISP, and then click Properties on the menu that appears.
- Click Server Type, click TCP/IP Settings, and then enter the DNS server
settings provided by your ISP.
If you are accessing the Internet using a proxy server or other LAN-based
connection, use the following steps:
- In Control Panel, double-click Network.
- Click the TCP/IP protocol, and then click Properties.
- Click the DNS Configuration tab, and then enter the DNS server settings
provided by your ISP.
Default Gateway Settings
If you are accessing the Internet by using Dial-Up Networking, use the
following steps:
- Click Start, point to Programs, point to Accessories, and then click
Dial-Up Networking.
- Use the right mouse button to click the connection used to connect to
your ISP, and then click Properties on the menu that appears.
- Click Server Type, click TCP/IP Settings, and then click the "Use
default gateway on remote network" check box to select it.
If you are accessing the Internet using a proxy server or other LAN-based
connection, use the following steps:
- In Control Panel, double-click Network.
- Click the TCP/IP protocol, and then click Properties.
- Click the Gateway tab, enter the IP address of the gateway provided by
your ISP in the New Gateway box, and then click Add.
NOTE: If you are accessing the Internet using a proxy server, you may not
need to configure the TCP/IP protocol to use a default gateway when
accessing a remote network. To find out if your proxy server requires a
default gateway, contact your system or network administrator.
Additional Troubleshooting Steps
To troubleshoot the problem further, follow these steps. After
performing each step, check to see if the problem has been resolved.
- Attempt to connect to another Web site to verify that the problem does
not occur with another site. If the problem does not occur with another
site, contact the administrator of the site to which you originally
tried to connect to verify that the site is currently available.
- Determine if the global TCP/IP settings conflict with the TCP/IP
settings for the connection used to connect to your ISP. To do so,
follow these steps:
NOTE: Make sure to make a note of any settings that you remove while
performing the following steps. If your computer is connected to a
network and you are using the TCP/IP protocol to access the network
(in addition to the Internet), you may need to replace the settings
after the problem has been resolved.
a. In Control Panel, double-click Network.
b. Click the TCP/IP protocol, and then click Properties.
c. If the Specify An Address option is selected on the IP Address tab
and an IP address has been entered in the IP Address box, remove the
IP address from the IP Address box.
d. Click the Gateway tab, and then remove all gateways from the
Installed Gateways list.
e. Click the DNS Configuration tab. If the Enable DNS option is
selected, click Disable DNS.
If these steps resolve the problem, the global TCP/IP settings that you
removed conflict with the TCP/IP settings for the connection used to
connect to your ISP. If your computer is not connected to a network, or
you are not using the TCP/IP protocol to access the network, you do not
need to perform any additional steps to troubleshoot this problem. The
TCP/IP settings that you removed do not need to be replaced.
However, if your computer is connected to a network and you are using
the TCP/IP protocol to access the network, you may be unable to access
the network until you replace the TCP/IP settings that you removed. To
prevent this problem from reoccurring when you replace the settings,
contact your system or network administrator to verify that the
settings are accurate.
- Verify that Internet Explorer is not configured to connect to the
Internet using both Dial-Up Networking and a proxy server. To do so,
follow these steps:
a. Use the right mouse button to click the Internet icon on the
desktop, and then click Properties on the menu that appears.
b. If you are using a version of Internet Explorer earlier than version
3.0, verify that the Use AutoDial check box on the AutoDial tab and
the Use Proxy Server check box on the Advanced tab are not both
selected.
If you are using Internet Explorer 3.0, verify that the Connect To The
Internet As Needed and Connect Through A Proxy Server check boxes on
the Connection tab are not both selected.
NOTE: If you connect to the Internet using a Dial-Up Networking
connection, you cannot access Web sites if the Use Proxy Server or
Connect Through A Proxy Server check box is selected. If you connect to
the Internet using a proxy server, you may be able to access Web sites
if the Use AutoDial or Connect To The Internet As Needed check box is
selected, but configuring Internet Explorer in this manner is not
recommended.
If you access the Internet using a proxy server and the steps described
in this article do not resolve the problem, the problem may be caused
by incorrect proxy server settings. For information about trouble-
shooting proxy server settings, please see the following article in
the Microsoft Knowledge Base:
ARTICLE-ID: Q139546
TITLE : Troubleshooting Internet Explorer and Proxy Servers
- Extract a new copy of the Wsock32.dll file from your original Windows
95 disks or CD. The Wsock32.dll file is located in the Win95_11.cab
cabinet file on the CD-ROM or in the Win95_12.cab cabinet file on disk
12.
For information about using the Extract tool, type "extract" (without
quotation marks) at a command prompt, or see the following article in
the Microsoft Knowledge Base:
ARTICLE-ID: Q129605
TITLE : How to Extract Original Compressed Windows Files
- Empty Internet Explorer's cache. To empty the cache if you are using a
version of Internet Explorer earlier than version 3.0, click Options on
the View menu in Internet Explorer, click the Advanced tab, and then
click Empty in the Cache area. To empty the cache if you are using
Internet Explorer 3.0, click Options on the View menu in Internet
Explorer, click the Advanced tab, click Settings in the Temporary
Internet Files area, and then click Empty Folder.
- Use the PING command to verify that the TCP/IP protocol is functioning
properly. To do this, click Start, point to Programs, click Command
Prompt, and type the following commands at the command prompt (press
ENTER after each command)
ping 127.0.0.1
ping <address>
where <address> is the IP address of your computer. If the TCP/IP
protocol is functioning properly, four lines that appear similar to
the following lines are displayed
Reply from <address>: bytes=32 time=1ms TTL=32
where <address> is the IP address that you used with the PING
command. If a "Request timed out" or other similar error message is
displayed, the TCP/IP protocol may not be functioning properly and
may need to be reinstalled.
NOTE: If you do not know the IP address of your computer, click the
Start button, click Run, type "winipcfg" (without quotation marks)
in the Open box, and then click OK. When the IP Configuration dialog
box appears, click PPP Adapter in the list of adapters. Your
computer's IP address appears in the IP Address box.
MORE INFORMATION
The error message stated above can also occur if you have the PPP/SLIP
Adapter from FTP Software installed in Network properties. Removing this
adapter and TCP/IP stack resolves the problem. If you later decide you
want to use the PPP/SLIP Adapter from FTP Software, you can add it again
in Network properties.
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