The information in this article applies to:
- Microsoft Internet Explorer version 3.0, 4.0 for Windows 95
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
SYMPTOMS
When you use Microsoft Internet Explorer to access the Internet, you may
receive the following error message:
IEXPLORE caused an invalid page fault in module Kernel32.dll
CAUSE
This problem can be caused by any of the following situations:
- One or more dynamic link libraries (DLLs) are located on the desktop.
- Internet Explorer's internal Java Just-In-Time (JIT) compiler is
enabled, and the Web page you are loading contains a Java program
that is incompatible with the compiler.
- Internet Explorer is configured to automatically use items that show
active content, and the Web page you are loading contains active
content that is not functioning properly.
- The third-party display driver you are using is damaged or incompatible
with Windows 95.
- You are using Active Server Pages (ASP) to perform an ODBC query on a
database on an Internet Information Server (IIS), or you are running a
large ASP file while Secured Sockets Layer (SSL) security is enabled.
RESOLUTION
To work around this problem, use the appropriate method:
- Configure Windows 95 so that DLLs are not hidden, and then rename or
move any DLLs located on the desktop. To configure Windows 95 so that
DLLs are not hidden, follow these steps:
1. Double-click My Computer.
2. On the View menu, click Options, and then click the View tab.
3. Click to select Show All Files, and then click OK.
To rename a file on the desktop, use the right mouse button to click
the file, click Rename on the menu that appears, type the new name for
the file, and then press ENTER. To move a file on the desktop, drag the
file from the desktop to a folder on your hard disk in My Computer or
Windows Explorer.
- Disable Internet Explorer's internal Java JIT compiler. To do so, click
Options on the View menu in Internet Explorer, click the Advanced tab,
and then click the Enable Java JIT Compiler check box in the Active
Content area to clear it.
For additional information about troubleshooting problems with Java
programs in Internet Explorer 3.0, please see the following article in
the Microsoft Knowledge Base:
ARTICLE-ID: 168806
TITLE : Troubleshooting Java Problems in Internet Explorer 3.x
- Configure Internet Explorer so that it does not automatically use items
that show active content, such as vertical marquees or animations. To
do so, click Options on the View menu in Internet Explorer, click the
Security tab, and then click the Enable ActiveX Controls And Plug-Ins
check box in the Active Content area to clear it.
For additional information about troubleshooting problems with active
content in Internet Explorer, please see the following article in
the Microsoft Knowledge Base:
ARTICLE-ID: Q154036
TITLE : Troubleshooting Active Content in Internet Explorer
- Configure Windows 95 to use the Standard Display Adapter (VGA) or Super
VGA display adapter type. To do so, follow these steps:
1. In Control Panel, double-click Display.
2. Click the Settings tab, and then click Change Display Type.
3. In the Adapter Type area, click Change, and then click Show All
Devices.
4. Click (Standard Display Types) in the Manufacturers box, click
Standard Display Adapter (VGA) or Super VGA in the Models box, and
then click OK.
If the problem does not occur after performing these steps, the third-
party display driver you are using may be damaged or incompatible with
Windows 95. If the display driver is damaged, you may be able to work
around the problem by reinstalling the driver from the disk provided by
the hardware manufacturer. If the problem continues to occur after
reinstalling the driver, contact the driver's manufacturer to inquire
about protected-mode drivers for your display adapter for use with
Windows 95.
NOTE: If you are running Internet Explorer 4.0 or 4.01, you may be able
to work around this issue by uninstalling the Windows Desktop update
component. For information about how to do so, please see the following
article in the Microsoft Knowledge Base:
ARTICLE-ID : Q165695
TITLE : How to Add or Remove Windows Desktop Update
For additional information about troubleshooting problems with active
content in Internet Explorer, please see the following article in the
Microsoft Knowledge Base:
ARTICLE-ID: Q154036
TITLE : Troubleshooting Active Content in Internet Explorer
- WARNING: Using Registry Editor incorrectly can cause serious problems
that may require you to reinstall Windows 95. Microsoft cannot
guarantee that problems resulting from the incorrect use of Registry
Editor can be solved. Use Registry Editor at your own risk.
NOTE: For information about how to edit the registry, view the
Changing Keys And Values online Help topic in Registry Editor
(Regedit.exe). Note that you should make a backup copy of the
registry files (System.dat and User.dat) before you edit the registry.
Change the value of the BufferingOn value to "1" in the following
registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\ASP\
Parameters
For more information, see the following article in the Microsoft
Knowledge Base:
ARTICLE-ID: Q164073
TITLE : Using ASP Queries with SSL Enabled
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