Error Message: Assert Failed: Process: Iexplore.exe

Last reviewed: September 29, 1997
Article ID: Q166116

The information in this article applies to:

  • Microsoft Internet Explorer version 4.0 for Windows 95
  • Microsoft Internet Explorer version 4.0 for Windows NT 4.0

SYMPTOMS

When Internet Explorer opens a Hypertext Markup Language (HTML) page that includes an OBJECT tag, you may receive the following error message:

   Assert Failed: Process: Iexplore.exe PID:xx TID:xx
   File:<pathname\filename>(xxx)
   0 && "Unexpected call to client site."

CAUSE

The OBJECT tag in the HTML file is referring to an ill-behaved OLE or ActiveX control.

RESOLUTION

To resolve this problem, contact the individual who wrote the ActiveX control (the author) and tell that author about the error message that you are receiving. The author of the control will need to redesign it so that the error message does not occur.

MORE INFORMATION

Assert errors usually occur when an object attempts to call an interface method when it is not allowed or expected to.


Additional query words: 4.00
Keywords : kberrmsg msient msiew95 ntsrv ntwkst osr2 win95
Version : 4.0
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 29, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.