Cannot View Icons or Move/Resize Desktop Components

Last reviewed: October 7, 1997
Article ID: Q166479
The information in this article applies to:
  • Microsoft Internet Explorer version 4.0 for Windows 95
  • Microsoft Internet Explorer version 4.0 for Windows NT 4.0

SYMPTOMS

You may experience any of the following symptoms:

  • You cannot see any icons in My Computer or Control Panel.
  • You cannot change Web View setting in My Computer or Windows Explorer.
  • You cannot move or resize desktop components.

CAUSE

You have disabled the "Enable ActiveX controls and plug-ins" option in Internet Explorer, and you are running in Shell Integration mode.

Desktop components are moved or resized using ActiveX controls. If you disable ActiveX controls and plug-ins, you disable the ability to move or resize desktop components. If you are not using Web View in My Computer or Windows Explorer, you are still be able to see icons in My Computer or Control Panel. When a window is using Web View mode, Windows Explorer uses ActiveX controls and plug-ins to display the items within a folder. If you disable ActiveX controls and plug-ins, you disable the ability to display folder contents.

RESOLUTION

To resolve this issue, use either of the following methods:

Re-Enable ActiveX Controls And Plug-Ins

  1. In Internet Explorer, click Internet Options on the View menu.

  2. Click the Security tab.

  3. Click Custom, and then click Settings.

  4. Scroll to the Run ActiveX Controls and Plugins category.

  5. Click Enable.

  6. Click OK until all dialog boxes are closed.

Disable Shell Integration Mode

  1. Click Start, point to Settings, and then click Control Panel.

  2. Click Add/Remove Programs, and then click the Install/Uninstall tab.

    NOTE: If no icons are displayed in Control Panel, locate and double- click the Appwiz.cpl file to start the Add/Remove Programs tool.

  3. In the list of installed programs, click Microsoft Internet Explorer 4.0, and then click Add/Remove.

  4. Click "Remove Web Integrated Desktop, but keep the Internet Explorer 4.0 Web browser", and then click OK.

  5. Click Yes when you are prompted to restart the computer.

    Note: You may be prompted to move items from your Recycle Bin or close any running programs so that Internet Explorer can reconfigure your system.

    For additional information about this option, see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q165695
    
          TITLE     : How to Add/Remove Web Integrated Desktop
    
    

STATUS

Microsoft is researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Additional query words: 4.00
Keywords : kbenv kbui msient msiew95
Version : 4.0
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: October 7, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.