Internet Explorer Prompts to Download Files

Last reviewed: November 19, 1997
Article ID: Q170802
The information in this article applies to:
  • Microsoft Internet Explorer version 3.02 for Windows 95
  • Microsoft Internet Explorer version 3.02 for Windows NT 4.0

SYMPTOMS

When you attempt to open a document in Internet Explorer, Internet Explorer may prompt you to save the file to a disk instead of opening the document.

CAUSE

This behavior can occur if the Multipurpose Internet Mail Extension (MIME) content type for the document type is not defined or is incorrect.

RESOLUTION

To resolve this issue, specify the correct content type. To do this, follow these steps:

  1. Try to open the document again, and then click Save To Disk when you are prompted to either Open or Save To Disk. This saves the file to the Windows desktop. Note that on a Windows 95-based computer, the path to the desktop is Windows\Desktop, but on a Windows NT 4.0-based computer the path to the desktop is Winnt\Profiles\<username>\Desktop.

  2. Once the file has finished downloading to your computer, verify that you are able to view the file's extension. To do so:

a. Double-click My Computer, and then click Options on the View menu.

b. Click the View tab, and verify that Show All Files is selected and that

   "Hide MS-DOS file extensions for file types that are registered" is not
   selected. Note that on a Windows NT 4.0-based computer, you must verify
   that Show All Files is selected and that "Hide file extensions for
   known file types" is not selected. If needed, click either or both to
   select or clear them, and then click OK.

  • View the downloaded file on your desktop and note the file's extension. For example, if you downloaded a Microsoft Word document, the file has a .doc extension.

  • Double-click My Computer.

  • On the View menu, click Options, and then click the File Types tab.

  • In the Registered File Types box, click the file type of the document you are attempting to open (this is the file extension noted in step 3), and then click Edit.

  • In the Content Type (MIME) box, click the appropriate content type. Note that you may be unable to determine the appropriate content type even if you know the file's extension, as there are many different file extensions created by different programs. If the appropriate content type is not available, or you are unable to determine the appropriate content type, contact the author of the Web page or the Web server administrator to determine what additional program is needed to open the file.

  • Click OK until all dialog boxes are closed.


  • Additional query words: 3.02
    Keywords : kbtool msient msiew95
    Version : 3.02
    Platform : WINDOWS


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    Last reviewed: November 19, 1997
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