Garbled Text in List Boxes and Drop-Down List Boxes

Last reviewed: September 29, 1997
Article ID: Q171157

The information in this article applies to:

  • Microsoft Internet Explorer versions 3.0, 3.01, 3.02, 4.0 for Windows 95
  • Microsoft Internet Explorer versions 3.0, 3.01, 3.02, 4.0 for Windows NT 4.0

SYMPTOMS

When you view a Web page using Internet Explorer with multilanguage support enabled, the text within list boxes or drop-down list boxes may appear garbled or unintelligible.

CAUSE

This behavior can occur if you are viewing a Web page that contains Double-Byte Character Set (DBCS) characters, such as Chinese or Japanese. The Windows system font, which is used within list boxes and drop-down list boxes, is not capable of displaying DBCS characters.

RESOLUTION

To resolve this issue, install the appropriate localized (foreign language) version of Windows 95 or Windows NT. Doing so installs a system font that is capable of displaying DBCS characters.


Additional query words: 3.00 4.00
Keywords : kbenv kbui msient msiew95
Version : WINDOWS:3.0,3.01,3.02,4.0
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 29, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.