Error Starting Computer with Damaged Shortcuts on Start Menu

Last reviewed: November 26, 1997
Article ID: Q171665

The information in this article applies to:

  • Microsoft Internet Explorer versions 4.0, 4.01 for Windows 95
  • Microsoft Internet Explorer versions 4.0, 4.01 for Windows NT 4.0

SYMPTOMS

When you start your computer, you may receive the following error message:

   Internet Explorer caused a General Protection Fault in module
   Shell32.dll

CAUSE

This problem can occur if there are damaged shortcut (.lnk) files on the Start menu.

RESOLUTION

To work around this problem, remove all shortcut files from the Start menu, and then create them again.

Deleting the Shortcuts

To delete the shortcuts, follow the steps appropriate for your version of Windows.

Windows 95:

  1. Click Start, point to Programs, and then click Windows Explorer.

  2. In Explorer, find the Start Menu folder.

    The default location for the Start Menu folder is C:\Windows\Start Menu.

  3. Locate a shortcut file.

    You can identify a shortcut item by its icon. A shortcut item will typically have an arrow on its lower-left corner.

  4. Right-click the shortcut, click Properties, and then click the Shortcut tab.

  5. Write down the following information about the shortcut:

           - The name of the shortcut  Listed at the top of the tab
    

           - Target Location           The folder in which the file is
                                       located.
    
           - Target                    The full path to the file that the
                                       shortcut points to.
    
    

  6. Delete the shortcut.

    For information about deleting a file, click Start, click Help, click the Index tab, type "deleting, f" (without quotation marks), double- click the "files or folders" topic under deleting, and click "Deleting a file or folder."

  7. Repeat steps 4-6 for each shortcut in the Start Menu folder.

To delete the shortcuts in Windows NT:

  1. Click Start, point to Programs, and then click Windows NT Explorer.

  2. In Explorer, find the Start Menu folder.

    The default location for the Start Menu folder is c:\WinnT\Profiles\<Username>\Start Menu in Windows NT

  3. Locate a shortcut file.

  4. Right-click the shortcut, click Properties, and then click the Shortcut tab.

  5. Write down the following information about the shortcut:

           - The name of the shortcut  Listed at the top of the tab
    

           - Target Location           The folder in which the file is
                                       located.
    
           - Target                    The full path to the file that the
                                       shortcut points to.
    
    

  6. Delete the shortcut.

    For information about deleting a file, click Start, click Help, click the Index tab, type "deleting: files" (without the quotation marks), double-click the "files" topic, and double-click the "To delete a file or folder" topic.

  7. Repeat steps 4-6 for each shortcut in the Start Menu folder.

Re-creating the Shortcuts

To re-create the shortcuts:

  1. In Windows Explorer, open the Start Menu folder.

  2. On the File menu, point to New, and click Shortcut.

    The Create Shortcut Wizard will be started.

  3. In the Command Line box, type the location of the file you want to create a shortcut to (or click Browse to locate the file and click Open), and then click Next.

    NOTE: The location of the file should be the "Target" name you wrote down in step 5 of the previous procedure. If the Target Location is Desktop, follow these steps to create the shortcut:

    a. Right-click the icon for the file on the desktop.

    b. Click Create shortcut.

    c. Drag the new shortcut to the Start Menu folder.

  4. In the "Select a name for the shortcut" box, type a name for the shortcut (you may want to use the name you wrote down in the previous procedure).

  5. Click Finish.

    The shortcut will be created in the Start Menu folder.

  6. Repeat steps 2-5 for each shortcut you need to re-create.


Additional query words: 4.00
Keywords : kberrmsg msient msiew95
Version : WINDOWS:4.0
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: November 26, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.