System Agent Does Not Function After Uninstalling Task Scheduler

Last reviewed: September 29, 1997
Article ID: Q172080

The information in this article applies to:

  • Microsoft Internet Explorer version 4.0 for Windows 95

SYMPTOMS

After you uninstall Task Scheduler, the System Agent icon does not appear on the taskbar. If you attempt to start System Agent by using the Start menu, you may receive the following error message:

   Cannot restart System Agent, reinstall MS Plus

In addition, when you start Windows 95, you may receive the following error message:

   Essential file is missing on bootup
   Sage.vxd

CAUSE

This behavior can occur if you uninstall Task Scheduler. Task Scheduler replaces System Agent, but System Agent is not restored when you uninstall Task Scheduler.

RESOLUTION

To resolve this issue, reinstall System Agent. For information about reinstalling System Agent, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q133191
   TITLE     : Reinstalling System Agent Without Losing Scheduled Tasks

MORE INFORMATION

Task Scheduler is an Internet Explorer component that you can install using the Add/Remove Programs tool in Control Panel after Internet Explorer is installed.

For information about how to add or remove Internet Explorer components, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q171229
   TITLE     : How to Add and Remove Internet Explorer 4.0 Components


Additional query words: 4.00 sage systray system tray
Keywords : kberrmsg kbtool msiew95
Version : WINDOWS:4.0
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 29, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.