The information in this article applies to:
- Microsoft Internet Explorer version 4.0 for Windows 95
- Microsoft Internet Explorer version 4.0 for Windows NT 4.0
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
SYMPTOMS
When you restart your computer after you install Internet Explorer 4.0 or
change folder options, only your desktop wallpaper may be displayed (the
Start button, taskbar, and desktop icons may not be displayed).
CAUSE
This behavior can occur if the Windows Desktop Update is installed and
either of the following conditions exists:
- You install Internet Explorer 4.0 on a Compaq computer running Windows
95 and using Cpqshell instead of Windows Explorer as the interface (or
"shell"). This problem is caused by the interaction between Compaq's
Home Base user interface shell and Internet
Explorer 4.0.
NOTE: Some Compaq Presario computers are pre-configured to use
Cpqshell.
- You changed Advanced settings on the View tab of Folder Options
properties in a "rooted" instance of Windows Explorer. For example, you
enabled Show All Files instead of "Do not show hidden or system files"
under Hidden Files.
NOTE: You can use any of the following methods to run a "rooted"
instance of Windows Explorer:
- Click Start, point Settings, click Taskbar & Start Menu, click the
Start Menu Programs tab, and then click Advanced. This applies to
Windows 95 only.
- Start MSN, The Microsoft Network, version 1.x. This problem does not
occur with MSN 2.x, which uses Internet Explorer instead of Windows
Explorer. This applies to Windows 95 only.
- You start Windows Explorer using the "/root" (without quotation
marks) command-line switch. For information about using the "/root"
(without quotation marks) command-line switch with Windows Explorer,
please see the following articles in the Microsoft Knowledge Base:
ARTICLE-ID: Q130510
TITLE : Command-Line Switches for Windows Explorer
ARTICLE-ID: Q152457
TITLE : Windows NT Explorer Command-Line Options
NOTE: This applies to both Windows 95 and Windows NT 4.0.
- You right-click an area on the desktop or Windows Explorer, and then
click Explorer From Here. Power Toys includes an Explore From Here
shell extension that runs a "rooted" instance of Windows Explorer.
RESOLUTION
To resolve this problem, follow the steps in the appropriate section
below:
Running Windows 95 on a Compaq Computer Using Cpqshell or Home Base
While this problem does not cause damage or data loss, you must manually
restart your computer three times in order to complete the Windows Desktop
Update component installation. To resolve this problem, perform each of
the following methods (if needed) in the order in which they are listed
below:
Method 1
- Press CTRL+ESC to start Windows Task Manager.
- On the File menu, click Shutdown Windows.
- Click Restart, and then click Yes.
NOTE: You may need to repeat this process three times.
If this method does not resolve the problem, use Method 2 below.
Method 2
NOTE: This method is required if you have reinstalled the Compaq OEM
version of Windows 95.
- Press CTRL+ESC to start Windows Task Manager.
- On the Options menu, click Always on Top to deselect it.
- On the File menu, click Run Application.
- In the Open box, type "command" (without quotation marks), and then
click OK.
- At the command prompt, type the following command, and then press
ENTER:
copy explorer.exe microsoftexplorer.exe
- At the command prompt, type "exit" (without quotation marks), and then
press ENTER.
- On the File menu, click Shutdown Windows.
- Click Restart, and then click Yes.
After you log on to Compaq Home Base, the Start button, taskbar, and
desktop icons should display and function normally. If this is not the
case, use Method 3 below.
Method 3
NOTE: This method disables the Compaq Cpqshell interface.
- Press CTRL+ESC to start Windows Task Manager.
- On the Options menu, click Always on Top to deselect it.
- On the File menu, click Run Application.
- In the Open box, type "sysedit" (without quotation marks), and then
click OK.
- On the Window menu, click System.ini.
- In the [Boot] section of System.ini, place a semi-colon before the
Shell=<path>\CPQSHELL.EXE line, and then add a Shell=Explorer.exe line
as follows:
;Shell=<path>\CPQSHELL.EXE
Shell=Explorer.exe
- On the File menu, click Exit.
- Click Yes.
- On the File menu, click Shutdown Windows.
- Click Restart, and then click Yes.
- When you receive the following prompt, click No:
Do you wish to keep your Compaq software working?
Folder Options Changed in a "Rooted" Windows Explorer
This problem only occurs when you log on to Windows as the user who
changed
folder Options in the "rooted" instance of Windows Explorer. If you log on
to Windows (Windows 95 or Windows NT) as a different user or start in Safe
mode (Windows 95 only), this problem does not occur. To work around this
problem, follow the steps in the appropriate section below:
Windows 95:
WARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall Windows 95. Microsoft cannot guarantee that
problems resulting from the incorrect use of Registry Editor can be
solved. Use Registry Editor at your own risk.
NOTE: For information about how to edit the registry, view the Changing
Keys And Values online Help topic in Registry Editor (Regedit.exe). Note
that you should make a backup copy of the registry files (System.dat and
User.dat) before you edit the registry.
- Press CTRL+ESC to start Windows Task Manager.
- On the File menu, click Run Application.
- In the Open box, type "regedit" (without quotation marks), and then
click OK.
- Delete the Settings binary value under the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion
\Explorer\CabinetState
- On the Registry menu, click Exit.
- Press CTRL+ALT+DELETE, and then click Shut Down.
- Restart your computer.
Windows NT 4.0:
WARNING: Using Registry Editor incorrectly can cause serious, system-wide
problems that may require you to reinstall Windows NT to correct them.
Microsoft cannot guarantee that any problems resulting from the use of
Registry Editor can be solved. Use this tool at your own risk.
- Press CTRL+ALT+DEL, and then click Task Manager.
- On the File menu, click New Task (Run...).
- In the Open box, type "regedit" (without quotation marks), and then
click OK.
- Delete the Settings binary value under the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion
\Explorer\CabinetState
- On the Registry menu, click Exit.
- Press CTRL+ALT+DELETE, and then click Shut Down.
- Click Shutdown And Restart, and then click OK.
STATUS
This problem does not occur in Internet Explorer 4.01. To install
Internet Explorer 4.01, visit the following Microsoft Web site:
http://www.microsoft.com/ie/download/
For more information about this issue, visit the following Compaq Web
site:
http://www.compaq.com
MORE INFORMATION
If either of the resolutions above do not resolve this problem, follow
these steps (Windows 95 only):
- Press CTRL+ESC to start Windows Task Manager.
- On the File menu, click Run Application.
- In the Open box, type "system.ini" (without quotation marks), and then
click OK.
- Verify that the following line exists in the [Boot] section of the
System.ini file:
Shell=Explorer.exe
If the "Shell=" line contains a different file name, change it to
"Explorer.exe" (without quotation marks).
- On the File menu, click Exit, and then click Yes when you are prompted
to save the changes.
- In Task Manager, click Shutdown Windows on the File menu, and then
restart your computer.
If you are still unable to resolve this problem, uninstall Internet
Explorer 4.0. For information about how to do so, please see the following
articles in the Microsoft Knowledge Base:
ARTICLE-ID: Q166313
TITLE : Removing Internet Explorer 4.0 for Windows 95 Using
Ieremove.exe
ARTICLE-ID: Q166314
TITLE : Removing Internet Explorer for Windows NT 4.0 Using
Ieremove.exe
ARTICLE-ID: Q175610
TITLE : How to Manually Uninstall Internet Explorer 4.0
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