Err Msg: A Connection to the Server Could Not Be Established

Last reviewed: March 20, 1998
Article ID: Q175039
The information in this article applies to:
  • Microsoft Internet Explorer version 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer version 4.0 for Windows 95

SYMPTOMS

When you try to connect to a Web site after installing Internet Explorer, you may receive the following error message:

   A connection to the server could not be established.

Even though you are unable to access the Internet, you may be able to access an intranet Web site.

CAUSE

This error message can occur if the Wsock32n.dll file is not updated during the Internet Explorer 4.0 installation. This can occur if you upgrade Internet Explorer 3.02 to Internet Explorer 4.0 and you connect to the Internet using a SOCKS proxy server.

RESOLUTION

To resolve this problem, use either of the following methods:

Upgrade to Internet Explorer 4.01

Obtain Internet Explorer 4.01. To do so, visit the following Microsoft Web site:

   http://www.microsoft.com/ie/download/

Replace the Wsock32n.dll File

Extract and Replace the Wsock32n.dll File for Windows 95:

  1. Restart Windows 95, press the F8 key when you see the "Starting Windows 95" message, and then choose Safe Mode Command Prompt Only from the Startup menu.

  2. Rename the Wsock32n.dll file in the Windows\System folder to Wsock32n.old by typing the following line and then pressing ENTER

          ren <drive>:\<windows>\system\wsock32n.dll wsock32n.old
    

    where <drive> is the drive letter on which the Windows folder is located, and <windows> is the name of the folder in which Windows is installed. For example:

          ren c:\windows\system\wsock32n.dll wsock32n.old
    

    NOTE: This procedure assumes you do not have a file named Wsock32n.old. If you do have a file by this name, use a file name extension that is not currently in use.

  3. Type the following line, and then press ENTER

          extract <drive>:<path>ie4_s4.cab /l <drive2>:<path2>
    

    where <drive> is the drive letter on which the Internet Explorer 4.0 Setup files are located, <path> is the path to the folder in which the Internet Explorer 4.0 Setup files are located, <drive2> is the drive letter to which to extract the Ie4_4.cab file, and <path2> is the path to the folder to which to extract the Ie4_4.cab file. For example:

          extract c:\intern~1.0se\ie4_s4.cab /l c:\intern~1.0se
    

  4. Type the following line, and then press ENTER

          extract <drive>:<path>wsock32n.dll /l <drive2>:\<windows>\system
    

    where <drive> is the drive letter on which the IE4_4.cab file is located, <path> is the path to the folder in which the IE4_4.cab file is located, <drive2> is the drive on which Windows is installed, and <path2> is the location of the Windows\System folder. For example:

          extract c:\intern~1.0se\ie4_4.cab wsock32n.dll /l c:\windows\system
    

  5. Restart your computer.

Extract and Replace the Wsock32n.dll File for Windows NT:

  1. Click Start, point to Programs, and then click Command Prompt.

  2. At the command prompt, type the following commands, pressing ENTER

ren <drive>:\<windows>\system32\wsock32n.dll wsock32n.old

   where <drive> is the drive letter on which the Windows folder is
   located, and <windows> is the name of the folder in which Windows is
   installed. For example:

      ren c:\windows\system32\wsock32n.dll wsock32n.old

   NOTE: This procedure assumes you do not have a file named Wsock32n.old.
   If you do have a file by this name, use a file name extension that is
   not currently in use.

  • Type the following line, and then press ENTER

          extract <drive>:<path>ie4nt_s4.cab /l <drive2>:<path2>
    

    where <drive> is the drive letter on which the Internet Explorer 4.0 Setup files are located, <path> is the path to the folder in which the Internet Explorer 4.0 Setup files are located, <drive2> is the drive letter to which to extract the Ie4nt_4.cab file, and <path2> is the path to the folder to which to extract the Ie4nt_4.cab file. For example:

          extract c:\intern~1.0se\ie4nt_s4.cab /l c:\intern~1.0se
    

  • Type the following line, and then press ENTER

          extract <drive>:<path>wsock32n.dll /l <drive2>:\<windows>\system32
    

    where <drive> is the drive letter on which the IE4nt_4.cab file is located, <path> is the path to the folder in which the IE4nt_4.cab file is located, <drive2> is the drive on which Windows is installed, and <path2> is the location of the Windows\System32 folder. For example:

          extract c:\intern~1.0se\ie4_4.cab wsock32n.dll /l
           c:\windows\system32
    

  • Click Start, click Shut Down, click [ASCII 147]Close all programs and log on as a different user.[ASCII 148], and then click Yes.

    STATUS

    This problem is fixed in Internet Explorer 4.01.

    MORE INFORMATION

    The version of the Wsock32n.dll file installed by Internet Explorer 4.0 is the same version as the file installed with Internet Explorer 3.02, and therefore not updated. The version of the Wsock32n.dll file included in Internet Explorer 4.0 is 5.1.02, and the file size is 26,160 bytes.

    For more information about using the Extract tool, please see the following article in the Microsoft Knowledge Base:

       ARTICLE-ID: Q129605
       TITLE     : How to Extract Original Compressed Windows Files
    
    
    For information about proxy servers, please see the following article in
     the Microsoft Knowledge Base:
    
       ARTICLE-ID: Q135982
       TITLE     : How to Configure Internet Explorer to Use a Proxy Server
    

  • Additional query words: 4.00
    Keywords : kberrmsg msient msiew95
    Version : WINDOWS:4.0
    Platform : WINDOWS


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    Last reviewed: March 20, 1998
    © 1998 Microsoft Corporation. All rights reserved. Terms of Use.