Unable to View Internet Shortcuts

Last reviewed: November 26, 1997
Article ID: Q175306
The information in this article applies to:
  • Microsoft Internet Explorer versions 3.02, 4.0, 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer versions 3.02, 4.0, 4.01 for Windows 95

SYMPTOMS

When you attempt to view a Web page by clicking an Internet shortcut on the Favorites menu in Internet Explorer, or double-clicking an Internet shortcut, Internet Explorer may not load the Web page specified in the Internet shortcut.

CAUSE

This behavior can occur if the Internet Shortcut file association does not associate an Internet shortcut with Internet Explorer.

RESOLUTION

To restore the Internet Shortcut file association, use either of the following methods:

Reinstall Internet Explorer

Internet Explorer 3.02:

  1. Click Start, point to Programs, and then click Windows Explorer.

  2. On the View menu, click Options, and then click the File Types tab.

  3. If it exists, click Internet Shortcut, and then click Remove.

  4. Reinstall Internet Explorer 3.02.

Internet Explorer 4.0:

  1. Click Start, point to Programs, and then click Windows Explorer.

  2. On the View menu, click Folder Options, and then click the File Types tab.

  3. If it exists, click Internet Shortcut, and then click Remove.

  4. Reinstall Internet Explorer 4.0.

Re-create the File Association

Internet Explorer 3.02:

  1. Quit Internet Explorer.

  2. Click Start, point to Programs, and then click Windows Explorer.

  3. On the View menu, click Options, and then click the File Types tab.

  4. If it exists, click Internet Shortcut, and then click Remove.

  5. Restart Internet Explorer.

  6. In Windows Explorer, click Options on the View menu.

  7. On the File Types tab, click Internet Shortcut, click Edit, click OK and then click OK again.

Internet Explorer 4.0:

  1. Quit Internet Explorer.

  2. Click Start, point to Programs, and then click Windows Explorer.

  3. On the View menu, click Folder Options, and then click the File Types tab.

  4. If it exists, click Internet Shortcut, and then click Remove.

  5. Click New Type, and then in the Description Of Type box, type "Internet Explorer" (without quotation marks).

  6. In the Associated Extension box, type "URL" (without quotation marks).

  7. Click New, and then in the Action box, type "&Edit" (without quotation marks).

  8. In the "Application used to perform this action" box, type the following line, and then click OK:

          c:\program files\microsoft frontpage express\bin\fpxpress.exe
    

  9. Click New, and then in the Action box, type "Open" (without quotation marks).

  10. In the "Application used to perform this action" box, type the following line, and then click OK.

          rundll32.exe shdocvw.dll,OpenURL %1
    

  11. Click New, and then in the Action box, type "Print" (without quotation marks).

  12. In the "Application used to perform this action" box, type the following line, and then click OK:

          rundll32.exe C:\WINDOWS\SYSTEM\MSHTML.DLL,PrintHTML "%1"
    

  13. Click New, and then in the Action box, type "Printto" (without quotation marks).

  14. In the "Application used to perform this action" box, type the following line, and then click OK:

    rundll32.exe C:\WINDOWS\SYSTEM\MSHTML.DLL,PrintHTML "%1" "%2" "%3" "%4"

  15. Click Change Icon, and then click Browse.

  16. Double-click the following file:

          c:\Windows\System\Url.dll
    

  17. Click the first icon in the Current Icon box, click OK, and then click OK again.


Additional query words: 4.00
Keywords : kbenv msient msiew95
Version : WINDOWS:3.02,4.0
Platform : WINDOWS
Hardware : x86


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: November 26, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.