The information in this article applies to:
- Microsoft Internet Explorer versions 4.0, 4.01 for Windows 95
- Microsoft Internet Explorer versions 4.0, 4.01 for Windows NT 4.0
SYMPTOMS
When you start your computer, you may receive the following error message
if the Windows Desktop Update component is enabled:
Windows 95:
This program has performed an illegal operation and will be shut down.
If the problem persists, contact the program vendor.
When you click Details, one of the following details are displayed:
- Explorer caused an invalid page fault in module Explorer.exe at
<address>.
- Explorer caused an invalid page fault in module Shdocvw.dll at
<address>.
Note that this behavior can occur whether you start Windows 95 normally
or in Safe mode.
Windows NT 4.0:
An application error has occurred and an application error log is being
generated.
Explorer.exe
Exception: access violation (0xc0000005), Address: <address>
If you click OK or Close, only your desktop wallpaper may be displayed
(the Start button, taskbar, and desktop icons may not be displayed).
CAUSE
This behavior can occur if the Shdocvw.dll file is missing, damaged or the
wrong version.
The following tables list the version number, date, and size of the
Shdocvw.dll file for Internet Explorer 4.0 and 4.01 for Windows 95 and
Windows NT 4.0:
Internet Explorer 4.0:
Operating system Version Date Size (in bytes)
----------------------------------------------------------
Windows 95 4.71.1712.5 9/18/97 1,909,520
Windows NT 4.0 4.71.1712.5 9/18/97 1,910,032
Internet Explorer 4.01:
Operating system Version Date Size (in bytes)
----------------------------------------------------------
Windows 95 4.72.2106.7 11/18/97 1,916,688
Windows NT 4.0 4.72.2106.7 11/18/97 1,916,688
RESOLUTION
To resolve this behavior, follow the appropriate steps below for the
version of Internet Explorer you are using:
Internet Explorer for Windows 95
- Restart Windows 95, press the F8 key when you see the "Starting Windows
95" message, and then choose Command Prompt Only from the Startup menu.
- At the command prompt, type the following command, and then press
ENTER
ren <drive>:\<windows>\system\shdocvw.dll shdocvw.old
where <drive> is the drive letter on which the Windows folder is
located, and <windows> is the name of the folder in which Windows is
installed. For example:
ren c:\windows\system\shdocvw.dll shdocvw.old
NOTE: This procedure assumes you do not have a Shdocvw.old file already
located on your hard disk. If this file already exists, use a file name
extension that is not currently in use.
- At the command prompt, type the following command, and then press
ENTER
extract /l <path1> <path2>\ie4_s3.cab ie4_3.cab
where <path1> is the path to the folder to which to extract the
Ie4_3.cab cabinet file, and <path2> is the path to the folder in which
the Internet Explorer 4.0 Setup files are located.
NOTE: If you downloaded Internet Explorer 4.0 from the Internet,
<path2> is location of the Internet Explorer 4.0 Setup files on your
hard disk. If you installed Internet Explorer 4.0 from a CD-ROM,
<path2> is either of the following paths:
- <drive>:\win95\eng\packages for Internet Explorer 4.0 Plus CD
- <drive>:\en\ie40 for Internet Explorer 4.0 Commemorative (1-800) CD
where <drive> is the driver letter of the CD-ROM drive that
contains the Internet Explorer 4.0 CD.
NOTE: If you are unable to access your CD-ROM drive in MS-DOS mode,
you need to load the real-mode CD-ROM driver and real-mode
Microsoft CD-ROM Extensions driver (Mscdex.exe), in your
Config.sys and Autoexec.bat files. For more information, please see
the following article in the Microsoft Knowledge Base:
ARTICLE-ID: Q135174
TITLE : Cannot Access CD-ROM Drive from MS-DOS Mode or
Command Prompt
- At the command prompt, type the following command, and then press
ENTER
extract /l <path1> <path2>\ie4_3.cab shdocvw.dll
where <path1> is the location of the Windows\System folder, <path2> is
the path to the folder in which the Ie4_3.cab cabinet file (extracted
in Step 3 above) is located.
- Restart your computer.
Internet Explorer for Windows NT 4.0
- Click OK to close the Dr. Watson error dialog box.
- Press CTRL+ALT+DELETE, and then click Task Manager to start Windows NT
Task Manager.
- On the Options menu, click Always On Top to clear the check mark.
- On the File menu, click New Task (Run...).
- Type "cmd" (without quotation marks) and then click OK.
- At the command prompt, type the following command, and then press
ENTER
ren <drive>:\<windows>\system32\shdocvw.dll shdocvw.old
where <drive> is the drive letter on which the Windows NT folder is
located, and <windows> is the name of the folder in which Windows NT is
installed. For example:
ren c:\winnt\system32\shdocvw.dll shdocvw.old
NOTE: This procedure assumes you do not have a file named Shdocvw.old.
If you do have a file by this name, use a file name extension that is
not currently in use.
- At the command prompt, type the following command, and then press
ENTER
extract /l <path1> <path2>\ie4nt_s2.cab ie4nt_2.cab
where <path1> is the path to the folder to which to extract the
Ie4nt_2.cab cabinet file, and <path2> is the path to the folder in
which the Internet Explorer 4.0 Setup files are located.
NOTE: If you downloaded Internet Explorer 4.0 from the Internet,
<path2> is location of the Internet Explorer 4.0 Setup files on your
hard disk. If you installed Internet Explorer 4.0 from a CD-ROM,
<path2> is either of the following paths:
- <drive>:\win95\eng\packages for Internet Explorer 4.0 Plus CD
- <drive>:\en\ie40 for Internet Explorer 4.0 Commemorative (1-800) CD
where <drive> is the driver letter of the CD-ROM drive that
contains the Internet Explorer 4.0 CD.
- At the command prompt, type the following command, and then press
ENTER
extract /l <path1> <path2>\ie4nt_2.cab shdocvw.dll
where <path1> is the location of the Winnt\System32 folder, <path2> is
the path to the folder in which the ie4nt_2.cab cabinet file (extracted
in Step 3 above) is located.
- At the command prompt, type "exit" (without quotation marks), and then
press ENTER.
- On the File menu, click Exit Task Manager.
- Press CTRL+ALT+DELETE, and then click Shutdown.
- Click Shutdown And Restart.
MORE INFORMATION
For more information about using the Extract tool, see the following
article in the Microsoft Knowledge Base:
ARTICLE-ID: Q129605
TITLE : How to Extract Original Compressed Windows Files
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