Err Msg: Setup Cannot Continue Because Files Are Missing...

Last reviewed: November 26, 1997
Article ID: Q176592
The information in this article applies to:
  • Microsoft Internet Explorer versions 4.0, 4.01 for Windows 95

SYMPTOMS

When you attempt to install Internet Explorer over a network from a shared installation files folder that was downloaded from the Internet to a Windows 95-based computer, you may receive the following error message:

   Setup cannot continue because files are missing from the
   installation directory. Please run Setup again and choose
   Recovery. This will download the missing files and continue
   setup.

NOTE: Internet Explorer installation files are downloaded to the Internet Explorer 4.0 Setup folder by default.

CAUSE

This error message can occur if the Ie4mfc40.cab cabinet file is missing from the installation files folder.

RESOLUTION

To resolve this behavior, have your network administrator download the Internet Explorer installation files to the Windows 95-based computer by following these steps:

  1. Click Start, and then click Run.

  2. In the Open box, type the following command (including quotation marks), and then click OK

          <path>\ie4setup.exe /c:"ie4wzd /s#e /d:0"
    

    where <path> is the full path to the Internet Explorer installation files folder.

    For example, if the Internet Explorer installation files are located in the Internet Explorer 4.0 Setup folder, type the following command (including quotation marks):

          c:\internet explorer 4.0 setup\ie4setup.exe /c:"ie4wzd /s#e /d:0"
    

    This starts the Active Setup Wizard.

  3. After the files are downloaded, copy or move the Ie4setup.exe file to the folder in which you downloaded the Internet Explorer installation files.

    NOTE: The Ie4setup.exe file is not copied to the installation files folder during the download.

MORE INFORMATION

When you download the Internet Explorer installation files from the Internet to a Windows 95-based computer, the Ie4mfc40.cab cabinet file is not downloaded if the following files are already installed on the computer:

  • Mfc40.dll
  • Msvcrt40.dll
  • Olepro32.dll

NOTE: These files are installed by Internet Explorer 3.x, Windows 95 OEM Service Release 2 (OSR2), and other Microsoft programs.

The procedure above downloads all of the Internet Explorer cabinet files, regardless of whether a particular file is already installed on the computer.

For additional information about this procedure, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q174680
   TITLE     : Downloading Internet Explorer for Windows 95 and Windows NT


Additional query words: 4.00
Keywords : kberrmsg kbsetup msiew95
Version : WINDOWS:4.0
Platform : WINDOWS


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Last reviewed: November 26, 1997
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