Error Message When You Click Search in Internet Explorer

Last reviewed: February 27, 1998
Article ID: Q178141
The information in this article applies to:
  • Microsoft Internet Explorer versions 4.0, 4.01 for Windows 95
  • Microsoft Internet Explorer versions 4.0, 4.01 for Windows NT 4.0

SYMPTOMS

When you click Search, you may receive the following error message:

   Internet Explorer Script Error

   An error has occurred in the script on this page.

     Line:  159
     Char:  3
     Error: 'gEngineList[...].dom' is not an object
     Code:  0

   Do you want to continue running scripts on this page?

CAUSE

This behavior can occur for either of the following reasons:

  • You have disabled all cookie use and you are using the Microsoft Search Settings control.
  • There is a damaged cookie in the Cookies folder.

RESOLUTION

To resolve this behavior, use the appropriate method:

Configure Internet Explorer to Accept Cookies

To configure Internet Explorer to accept cookies, follow these steps:

  1. Click Start, point to Settings, click Control Panel, and then double- click Internet.

  2. Click the Advanced tab.

  3. Under Cookies, click one of the following options:

        - Always Accept Cookies
        - Prompt Before Accepting Cookies
    

    NOTE: If you click Prompt Before Accepting Cookies, you receive a Security alert before any cookies are downloaded to your computer.

  4. Click OK.

Remove the Microsoft Search Settings Control

To remove the Microsoft Search Settings control, follow these steps:

  1. Click Start, point to Settings, click Control Panel, and then double- click Internet.

  2. On the General tab, click Settings.

  3. Click View Objects, right-click Microsoft Search Settings Control, and then click Remove.

  4. Close the Downloaded Program Files folder, click OK, and then click OK.

  5. Start Internet Explorer, and click No if you receive the following Security warning:

          Do you want to install and run Internet Explorer Search
          Enhancements?
    

    NOTE: If you receive the Security warning, do not complete the remaining steps. If you do not receive the Security Warning, complete the remaining steps.

  6. On the View menu, click Internet Options, and then click the Security tab.

  7. Click Reset, click OK, quit Internet Explorer, and then repeat steps 1-4.

Remove Damaged Cookies

  1. Quit Internet Explorer (if it is running).

  2. Click Start, point to Programs, and then click Windows Explorer or Windows NT Explorer.

  3. Double-click the drive on which Windows is installed (usually drive C).

  4. Double-click the Windows folder.

  5. Double-click the Cookies folder.

  6. Delete the cookie from http://home.microsoft.com.

  7. Quit Windows Explorer or Windows NT Explorer.

MORE INFORMATION

For more information about cookies, see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q154360
   TITLE     : "You Have Received a Cookie" Message in Internet Explorer


Additional query words: 4.00
Keywords : kbenv kberrmsg msient msiew95
Version : WINDOWS:4.0,4.01
Platform : WINDOWS


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Last reviewed: February 27, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.