Office Error Msg: "Cannot Find CTL3D.DLL" During Installation

Last reviewed: February 26, 1998
Article ID: Q113432
The information in this article applies to:
  • Microsoft Office for Windows, version 4.2

SYMPTOMS

When you install Disk 1 of Microsoft Office version 4.2 (compliance checking version), you receive the following error message:

   Cannot find CTL3D.DLL

NOTE: The file IS present in compressed form on Disk 1.

In addition to the above error message, you may also receive:

   Top Level Parser: Bad DLL Value

   -or-

   Top Level INF Parser: Bad DLL Data Value

   -or-

   Top Level INF Parser: Bad DLL Value

   -or-

   Processing Top Level information failed

You may not receive the full message in Windows 95. The first message may be skipped and the next two error messages may appear in a single dialog.

CAUSE

The ODBCINST.DLL, which is installed during Setup, requires CTL3D.DLL for correct installation. The error message occurs if either of the following is true:

  • This file is not present in the C:\WINDOWS\SYSTEM directory.

    -or-

  • CTL3D.DLL is not referenced in the SETUP.LST file that shipped on Disk 1 of the compliance checking version of Office 4.2.

WORKAROUND

To work around this problem, follow the procedure below. If you are a network administrator and need to do many installations of Office, the procedure is efficient and requires no additional changes for the workstation installations.

  • Add CTL3D.DLL to the SETUP.LST file before running setup:

    1. At the MS-DOS command prompt, switch to the floppy disk drive that

          contains the Setup disk. For example, if the Setup disk is in drive
          A, type "a:" (without the quotation marks).
    

    2. When the prompt changes to the desired drive letter (in this example,

          a:), type "copy SETUP.LST c:\setup.old" (without the quotation marks)
          and press ENTER.
    

    3. To edit this file in the MS-DOS Editor, type "edit SETUP.LST"

          (without the quotation marks), and press ENTER.
    

    4. In the [Files] section of the SETUP.LST file, type:

             CTL3D.DL_ = CTL3D.DLL
    
          NOTE: If you type CTL3D.DL_ = CTL3D,DLL (notice the comma), you
          receive the error message:
    
             There is insufficient memory or disk space to run setup.
             Setup requires at least 900K of free disk space. Try shutting
             down other applications, restarting Windows, or freeing some
             disk space.
    
       5. Choose Exit from the File menu in the MS-DOS Editor and save your
          changes.
    
    

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Additional query words: 4.20 CCP ODBC
Keywords : kberrmsg kbsetup
Version : 4.20
Platform : WINDOWS


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Last reviewed: February 26, 1998
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