Local Access Directory Unavailable with Workstation Installation

Last reviewed: September 16, 1996
Article ID: Q122657
The information in this article applies to:
  • Microsoft Office for Windows, versions 4.3, 4.3-CD, 4.3c, 4.3c-CD
  • Microsoft Access, version 2.0

SYMPTOMS

After you perform a Workstation installation of Microsoft Office for Windows version 4.3, when you run Microsoft Access, you may receive the following error message:

   Can't Update. Database or object is read-only.

Additionally, a Microsoft Access directory is not created on your local hard drive, and the working directory for the Microsoft Access icon is located on the network drive from which you ran Setup.

CAUSE

Microsoft Access version 2.0 has 7 files that must be run from a directory with Read/Write privileges. These files include the Wizard files (files with names beginning with "WZ and ending with ".MDA"), the UTILITY.MDA file, and the SYSTEM.MDA file (which contains preferences, and so on).

When you perform a workstation installation of Microsoft Office, these files are located on the network server from which you ran Setup. They are not copied to your local hard drive. Because of this, you receive the error message described above if you do not have Read/Write access to the Microsoft Access directory on the server.

WORKAROUNDS

To work around this problem, give each network user his or her own copy of the wizards by copying the library database files to each user's local hard disk (or personal directory on the server) and modify the MSACC20.INI file. To do this, use the following steps:

  1. At an MS-DOS command prompt, type the following commands to copy the library database files from the server to each user's local hard disk:

          copy f:\access\workdir\wztable.mda c:\access
          copy f:\access\workdir\wzbldr.mda c:\access
          copy f:\access\workdir\wzlib.mda c:\access
    

    NOTE: These commands assume that Microsoft Access is installed in the ACCESS directory on network drive F and that each user has Microsoft Access installed in the ACCESS directory on drive C. If this is not the case, modify the commands to use the correct drives and paths for your installation.

  2. Use any text editor (such as Notepad) to open the MSACC20.INI file in the Windows directory on each user's local hard disk. Modify the following lines

          [Libraries]
          F:\ACCESS\WORKDIR\WZLIB.MDA=RW
          F:\ACCESS\WORKDIR\WZTABLE.MDA=RW
          F:\ACCESS\WORKDIR\WZBLDR.MDA=RW
          F:\ACCESS\WORKDIR\WZQUERY.MDA=RW
          F:\ACCESS\WORKDIR\WZFRMRPT.MDA=RW
    

    to read:

          [Libraries]
          C:\ACCESS\WZLIB.MDA=RW
          C:\ACCESS\WZTABLE.MDA=RW
          C:\ACCESS\WZBLDR.MDA=RW
          F:\ACCESS\WORKDIR\WZQUERY.MDA=RW
          F:\ACCESS\WORKDIR\WZFRMRPT.MDA=RW
    

  3. Save and then close the MSACC20.INI file.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

For additional information, please see the following article(s) in the Microsoft Knowledge Base:

   ARTICLE-ID: Q117912
   TITLE     : PRB: User Needs Read/Write Privileges for WORKDIR Directory

   ARTICLE-ID: Q121662
   TITLE     : PRB: Cannot Share Some Microsoft Access Wizards


KBCategory: kbsetup kbnetwork
KBSubcategory:

Additional reference words: 2.00 4.30 4.30-CD 4.30c 4.30c-CD




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Last reviewed: September 16, 1996
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