OFF95: Fatal Exception Error While Find Fast Is Indexing

Last reviewed: March 10, 1997
Article ID: Q136647
7.00 WINDOWS kbtool kbtshoot

The information in this article applies to:

  • Microsoft Office for Windows 95, version 7.0

SYMPTOMS

After you install Microsoft Office, you may receive the following error message (in a blue screen) when Find Fast is indexing the files on your computer:

   A fatal exception 07 has occurred at 0028:C10210BC. The current
   application will be terminated.

CAUSE

This problem may occur when Find Fast updates an index on your computer.

Find Fast is installed by Microsoft Office to your Startup folder. This utility indexes files on your computer to speed up the process of finding documents from within any Microsoft office program. However, the problem described above may occur when Find Fast updates an index on your computer if there is a problem with one of the files that is being indexed.

RESOLUTION

Use the following steps to troubleshoot problems that you encounter using Find Fast:

  1. a. Make sure that the Find Fast shortcut is located in the

          <Windows>\Start Menu\Programs\Startup folder (where <Windows> is the
          folder to which you installed Microsoft Windows).
    

          If you have removed the Microsoft Office Find Fast Indexer icon, put
          it back in the Startup folder.
    

    b. Click the right mouse button on the Find Fast shortcut in My Computer

          or Windows Explorer, and then click Properties. Click the Shortcut
          tab.
    

    c. Modify the Target field on the Shortcut tab by adding the /v switch

          instead of the /noui (default) switch. For example, the value in the
          Target field may appear as follows:
    

             C:\MSOffice\Office\FINDFAST.EXE /v
    
          Adding this switch to the command line allows you to get detailed
          output in the log file. Removing the /noui switch allows you to view
          the Find Fast dialog box when it runs (when you start Windows) for
          troubleshooting purposes.
    
    

  2. Use Windows Explorer to search for all the *.ff* files on your hard disk drives. These are all the index and status files.

  3. Restart your computer while holding down the SHIFT key. This prevents the items in the Startup group from running.

  4. After Windows starts again, use My Computer or Windows Explorer to open the Startup folder (in Windows\Start Menu\Programs folder) and double- click the Find Fast icon. Allow Find Fast to create the indexes (they should still appear in list of indexes).

  5. After Find Fast crashes or hangs, locate the log file (Ffastlog.txt, located in the Windows\System folder) and open this file in Notepad. Remember that if you are forced to restart your computer, hold down the SHIFT key to prevent the items in the Startup folder from running.

    At the end of the log file, you will see either a filename or an error describing the problem that was encountered. If there is a filename at the end of the log file, copy the specified file to a floppy disk. Open the file in the appropriate program. If opening the file causes the program to hang, causes another problem, or appears to be damaged, this file is probably the cause of the Find Fast problem and should be removed from your hard disk drive.

    Even if the file does not hang the program, move the file from your hard disk drive to a floppy disk to see if you can run Find Fast without a problem. The file may be old or damaged in some other way.

  6. Repeat steps 3-5 as necessary.

  7. After you have removed all of the files (from your hard disk drive) that cause Find Fast Indexer to crash, you can open each of these files in the appropriate program and save the file again to see if this corrects the file (and therefore the Find Fast problem).

    If saving the file does not resolve the problem, you can save the file to the SYLK format (Microsoft Excel worksheet) or to the RTF format (Word document) and then back to the normal format to see if this corrects the problem.

  8. After the Find Fast Indexer runs without returning an error message or other problem, add the /noui switch back to the command line in the Target field for the Find Fast shortcut (See Step 1 above) and optionally remove the verbose switch (/v). Then restart your computer, this time without holding down the SHIFT key.

MORE INFORMATION

For additional information about the Find Fast Indexer, please see the following article(s) in the Microsoft Knowledge Base:

   ARTICLE-ID: Q135476
   TITLE     : OFF95: Office for Windows 95 Find Fast Indexer Overview

   ARTICLE-ID: Q135805
   TITLE     : OFF95: Nothing Appears Launching Find Fast From Startup
               Folder

REFERENCES

For more information about updating a Fast Find index, click the Index tab in Microsoft Office Help, type the following text

   Fast Find document index, updating

and then double-click the selected text to go to the "Update a Find Fast Index" topic.


KBCategory: kbtool kbtshoot
KBSubcategory: offwin

Additional reference words: 7.00 0028:C0FE0884 0028:C101E618 COFE

Keywords : offwin kbtool kbtshoot
Version : 7.00
Platform : WINDOWS


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Last reviewed: March 10, 1997
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