The information in this article applies to:
- Microsoft Office 97 for Windows
- Microsoft Excel 97 for Windows
- Microsoft Windows NT Workstation version 4.0
SYMPTOMS
In Microsoft Excel 97, if you point to Get External Data on the Data menu,
and then click Create New Query to create a new data source, you may
receive the following error message:
Microsoft Query
I/O error during save. You may have typed an invalid file name.
CAUSE
This problem may occur if all of the following conditions are true:
- Your computer is running Microsoft Windows NT version 4.0.
-and-
- You install Service Pack 3 (SP3) for Windows NT 4.0.
-and-
- You then perform a Run From Network Server (RFS) installation of
Microsoft Office 97 from a server that contains an administrative
installation of Microsoft Office 97.
NOTE: This problem does not occur if you are running Microsoft Windows 95,
if you perform a Typical or Custom installation of Microsoft Office 97 from
a CD or an administrative installation point, or if you install Microsoft
Office 97 before you install Service Pack 3.
WORKAROUND
To work around this problem, follow these steps:
- Quit all running programs.
- Use Windows NT Explorer to go to the Winnt\System32 folder on
the hard disk. Delete or rename the following file:
Odbc32.dll
- On the Start menu, point to Settings, and click Control Panel. In the
Control Panel, double-click Add/Remove Programs. Click the
Install/Uninstall tab. In the list of programs, click Microsoft Office
97. Then, click Add/Remove.
- In the Microsoft Office 97 Setup dialog box, click Remove All. When
you are prompted to remove Microsoft Office 97, click Yes. When you are
prompted to remove shared components, click Yes.
- After Microsoft Office 97 is removed from your computer, reconnect
to the network server that contains the administrative installation
point for Microsoft Office 97, and then run the Setup program located
on the server.
- Install Microsoft Office 97.
After you install Microsoft Office 97, start Microsoft Excel 97. You can
then create a new data source.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. We are researching this problem
and will post new information here in the Microsoft Knowledge Base as it
becomes available.
MORE INFORMATION
The following combination of factors cause this problem to occur:
- Service Pack 3 for Microsoft Windows NT 4.0 includes a copy of the file
Odbc32.dll. When you install Service Pack 3 on your computer,
Odbc32.dll is installed in the Winnt\System32 folder.
- When you install Microsoft Office 97 on your computer, the Setup
program checks for the existence of the Odbc32.dll file in the
Winnt\System32 folder. If the program locates a newer version of the
file, it assumes that certain keys exist in the registry. As a result,
the Setup program does not attempt to create or update the keys.
- If the Microsoft Office 97 Setup program detects that a newer version
of Odbc32.dll already exists in the Winnt\System32 folder, it does
not create the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\odbc.ini\ODBC File DSN\
DefaultDSNDir
The value of this key is usually the following:
C:\WINDOWS\ODBC\Data Sources
- If this key is missing and you create a new data source by using
Microsoft Excel 97 and Microsoft Query 97, the new data source is
created in the default installation folder. Usually, this folder is
Program Files\Microsoft Office\Office.
However, if you performed a Run From Network Server installation of
Microsoft Office 97, the default installation folder is located on
the network server. Because this folder is usually a read-only folder,
the new data source cannot be saved in the folder, and you receive the
error message.
If you install Microsoft Office 97 BEFORE you install Service Pack 3, the
Setup program creates the correct registry keys, and you are able to create
new data sources without receiving this error message.
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