The information in this article applies to:
- Microsoft Office 97 for Windows, Service Release 1 (SR-1)
SYMPTOMS
When you attempt to close a file, a dialog box is displayed with three
buttons: Cancel, Yes and OK. When you click them, the buttons perform
functions that you do not expect them to. For example, the buttons function
as described in the following table.
Button Function that is performed
---------------------------------------------------
Cancel The file is saved.
Yes The file is closed without saving changes.
OK The operation is cancelled.
CAUSE
This problem occurs if the following conditions are true:
- You install the Microsoft Office 97 SR-1 Patch on your computer.
-and-
- You make changes to a file, and then attempt to close the file.
NOTE: This problem does not occur in Microsoft Access 97 SR-1.
RESOLUTION
To resolve this problem, replace the Mso97.dll and Mso7enu.dll files on
your computer and run the Office 97 SR-1 Patch Setup again. To do this,
follow these steps:
- Press CTRL+ALT+DELETE to display the Close Program dialog box. Click
the OSA item and click End Task.
- Press CTRL+ALT+DELETE to display the Close Program dialog box. Click
the Findfast item and click End Task. Another dialog is displayed.
Click End Task. Press CTRL+ALT+DELETE again to display the Close
Program dialog box. Ensure that Findfast and OSA do not appear in the
list. If they do, Click the item and click End Task.
- Insert the Office 97 compact disc into your CD-ROM drive.
NOTE: If you have Microsoft Project 98 installed on your computer,
insert the Microsoft Project 98 CD-ROM instead of the Microsoft Office
97 CD-ROM.
- Using Windows Explorer, open the following folder on the CD-ROM drive:
<CD-ROM Drive>:\Office
where <CD-ROM Drive> is the drive letter for your CD-ROM drive (usually
drive D). For example, if your CD-ROM drive letter is D, open the
following folder:
D:\Office
- On the View menu, click Options. Click the View tab. Click to select
Show All Files. Click OK.
- Right-click the Mso97.dll file. On the shortcut menu, click Copy.
- Using Windows Explorer, open the following folder on your hard disk:
Program Files\Microsoft Office\Office
- On the Edit menu, click Paste.
- Repeat steps 3 through 7. In step 5, copy the Mso7enu.dll file instead
of the Mso97.dll file.
- In Windows Explorer or File Manager Run the patch Setup by double-
clicking the Sr1off97.exe file.
For additional information about the Office Startup Application (OSA),
please see the following article in the Microsoft Knowledge Base:
ARTICLE-ID: Q165071
TITLE : OFF97: Q&A: What Is the OSA and What Does It Do?
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. We are researching this problem
and will post new information here in the Microsoft Knowledge Base as it
becomes available.