How to Reregister Shared Programs in Office 95 & 97

Last reviewed: January 28, 1997
Article ID: Q134863
The information in this article applies to:
  • Microsoft Office for Windows 95, version 7.0
  • Microsoft Clipart Gallery, version 3.0
  • Microsoft WordArt, version 2.0
  • Microsoft Graph, version 5.0
  • Microsoft Office 97 for Windows

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, you should first make a backup copy of the registry files (System.dat and User.dat). Both are hidden files in the Windows folder.

SYMPTOMS

When you attempt to use one of the shared programs that is installed with Microsoft Office, you may receive the following error message:

   The server program, source file, or item cannot be found.
   You should reinstall the server program.

The shared programs that ship with Microsoft Office include:
  • Microsoft Clipart Gallery
  • Microsoft Map (Data Map Office 7.0 and earlier)
  • Microsoft Equation Editor
  • Microsoft Graph
  • Microsoft Organization Chart
  • Microsoft WordArt

CAUSE

This problem is caused by incorrect or missing OLE information in the Windows 95 or Windows NT 3.51 registry. When you try to insert an object created by Microsoft Graph, for example, and you get the error, it means that the information in the registry about where to find Microsoft Graph is missing or is incorrect.

RESOLUTION

To resolve this problem, re-register the shared program in question.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

NOTE: The shared programs that ship with Microsoft Office for Windows are self-registering.

To reregister shared programs

To reregister any of the shared programs, run the executable file (.exe) for the affected program. You can run the executable in any of several ways:

  • Double-click the executable from My Computer or Windows Explorer.

    -or-

  • Click Run on the Start menu, then click the Browse button to locate the appropriate executable file.

In many cases you will receive a message similar to the following:
  • Clipart Gallery may only be used to embed objects. It must be started from within another program.

    - or -

  • Clip Gallery is now configured to run on your computer

In most cases, the shared program should now be registered correctly.

Exporting Keys from the Registry

If the above method for registering the program does not work, use the following steps to try exporting keys related to the shared program, and then reregister the program:

   WARNING: Ensure that you have read through and are familiar with this
   procedure prior to attempting it. One missed step could have a
   significantly negative impact on your system!

  • In Windows 95, click the Start button, and then click Run.

  • In the Open box, type "REGEDIT" (without the quotation marks), then click OK.

  • Click the plus sign to the left of HKEY_CLASSES_ROOT

  • Scroll down to locate the shared program's registry key.

        NOTE: The shared programs are all referred to with a prefix of "MS," as
        in "MSWordArt2" or "MS_ClipArt_Gallery."
    

  • Click the key to select it.

  • On the Registry menu, click Export Registry File. In Save in, specify Desktop.

  • Provide a name for the registry file, then click Save. Look on the desktop to verify that the registry key has been saved there successfully.

  • Return to Regedit. With the Registry key still highlighted, click Delete on the Edit menu. When prompted with the question "Are you sure you want to delete this key?", click Yes.

  • Reregister the shared program by running its executable (.exe) file.

    Rebuilding the Original Office for Windows 95 Registry Settings

    If the problem persists, you may need to rebuild your original Office 95 registry entries by running Office Setup. To do this, use the following command

       <drive>:setup /y
    
    
    where <drive> is the drive that contains the Office Setup disk. This parameter will force Office for Windows 95 to go into maintenance mode. If you then click Reinstall, the Setup program will rewrite the registry based on your previous installation. Note that it will restore all of the program defaults.

    Reinstalling the Operating System

    If the problem still exists after following the steps listed above, you may need to reinstall your operating system. For instructions on how to reinstall Windows 95 or Windows NT, please consult your operating system documentation.


  • KBCategory: kbole kbsetup
    KBSubcategory: offsetup
    Additional reference words: applet registration 7.00 95 97


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    Last reviewed: January 28, 1997
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