OL97: Appointments Import Incorrectly with Foreign Settings

Last reviewed: January 19, 1998
Article ID: Q172917
The information in this article applies to:
  • Microsoft Outlook 97

SYMPTOMS

If you use the Microsoft Outlook 97 Import and Export Wizard to import a Calendar appointment that ends at 12:00 p.m., from a text file, the appointment time may import with an ending time of 00:00 A.M.

CAUSE

You used the English version of Outlook and your Windows Regional Settings are set to a foreign country that uses twenty-four hour time. Regional settings for German (Standard) and French (Standard) exhibit this behavior when importing appointments. Appointments export with the correct time.

RESOLUTION

In order to import the appointments with the correct time you must change your Windows Regional Setting to English (United States) prior to using the Outlook Import and Export Wizard.

Follow these steps to change your Regional Setting to English:

  1. Quit all programs.

  2. On the Windows Taskbar, click Start point to Settings, and then click Control Panel.

  3. In the Control Panel, double-click the Regional Settings icon.

  4. In the Regional Settings list, click to select English (United States) and then click OK.

  5. When prompted, restart your computer and then try to import the appointments.

MORE INFORMATION

Steps to Reproduce Behavior

The following steps demonstrate the above problem with incorrectly imported appointment times:

Exporting the Appointment

  1. Set your Windows Regional Setting to French (Standard).

  2. Start Outlook.

  3. Insert an appointment in today's date with a starting time of 10:00 A.M. and ending time of 12:00 P.M.

  4. On the File menu, click Import and Export to open the Import and Export wizard.

  5. In the "Choose an action to perform" list, click to select "Export to a file" and then click Next.

  6. In the "Select folder to export from" folder list, click to select your Calendar folder and click Next.

  7. In the "Create a file of type" list, click "Tab Separated Values (Windows)" and click Next.

  8. In the "Save exported file as" box, type

          c:\test.txt and click Next.
    

  9. Make sure that "Export 'Appointments' from the 'Calendar' folder" is selected and click Finish.

  10. If the Set Date Range box appears, make sure the start and end dates

        are before and after today's date, and then click OK.
    

After the export completes, you can open C:\Text.txt with Notepad and confirm that the appointment exported correctly with an ending time of 12:00 P.M.

Importing the Appointment

  1. Start Outlook.

  2. On the File menu, click Import and Export to open the Import and Export wizard.

  3. In the "Choose an action to perform" list, click to select "Import from Schedule+ or another program or file" and then click Next.

  4. In the "Select file type to import from" list, click to select "Tab Separated Values (Windows)" and then click Next.

  5. In the File to import box, type

          C:\Test.txt
    

    under Options, click "Do not import duplicate items" and click Next.

  6. In the "Select destination folder" folder list, click to select your Calendar folder and click Next.

  7. Make sure that "Import 'test.txt' into the 'Calendar' folder" is selected and click Finish.

The appointment imports with a start and end time of 00:00 a.m.
Keywords          : IntpImEx
Version           : WINDOWS:97
Platform          : WINDOWS
Issue type        : kbprb
Solution Type     : kbworkaround


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Last reviewed: January 19, 1998
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