SMTP: Err Msg: Network_read: Lost Network Connection

Last reviewed: March 9, 1998
Article ID: Q100709
2.10 3.00 MS-DOS kb3rdparty kbother kberrmsg kbfile

The information in this article applies to:

  • Microsoft Mail Gateway to SMTP, versions 2.1 and 3.0

SYMPTOMS

Microsoft Mail Gateway to SMTP may display this message:

   ERROR Network_read: Lost network connection
   SMTP_recv: system error

CAUSE

This error message appears if:

  • An error at the TCP or IP layer has occurred.
  • The other host has gone down.
  • The network between the Gateway computer and the other host has gone down.
  • The other host may require that the PUSH flag be sent to push the SMTP packet up to the SMTP software, instead of remaining in the incoming buffer.

RESOLUTION

You can test these possible causes by attempting to telnet to port 25 of the smarthost and resending the message. This can usually be done by pressing SPACEBAR and typing "25" (without the quotation marks) after the IP address on the telnet command line.

If the error message appears frequently, check the network with a protocol analyzer to determine the exact problem.

NOTE: Mail sent to IBM TCP/IP Version 2, Release 2 may result in this error message if the PUSH flag is not set. FTP's pc/TCP automatically sets the PUSH flag for outgoing packets. For Microsoft LAN Manager TCP/IP, please contact Microsoft LAN Manager support for information on the availability to automatically set the PUSH flag.

For Microsoft LAN Manager TCP/IP, ensure you are using version 2.2b (dated 2/1/94, 42,716 bytes) or later of the file TCPTSR.EXE. By default, TCPTSR.EXE is found in the LANMAN.DOS\DRIVERS\PROTOCOL\TCPIP directory. Then add the parameter ForcePushBit=1 to the [TCPIP] section of the PROTOCOL.INI file. It defaults to 0, but when it is set to 1, it causes the PUSH bit to be set on every outgoing packet.

MORE INFORMATION:

To obtain the latest version of TCPTSR.EXE upgrade (dated 09/06/95, 66,816 bytes):

You can find TCPTSRU.EXE (size: 54003 bytes) 
                        , a self-extracting file, on the following
services:
  • Microsoft's World Wide Web Site on the Internet

          On the www.microsoft.com home page, click the Support icon.
          Click Knowledge Base, and select the product.
    
          Enter kbfile TCPTSRU.EXE (size: 54003 bytes) 
                                  , and click GO!
          Open the article, and click the button to download the file.
    
    
  • Internet (anonymous FTP)

          ftp ftp.microsoft.com
          Change to the Softlib/Mslfiles folder.
          Get TCPTSRU.EXE (size: 54003 bytes) 
    
  • The Microsoft Network

          On the Edit menu, click Go To, and then click Other Location.
          Type "mssupport" (without the quotation marks).
          Double-click the MS Software Library icon.
          Find the appropriate product area.
          Locate and Download TCPTSRU.EXE.
    
  • Microsoft Download Service (MSDL)

          Dial (206) 936-6735 to connect to MSDL
          Download TCPTSRU.EXE (size: 54003 bytes) 
    

For additional information about downloading, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online
               Services


Additional reference words: 2.10 3.00 ERRMSG smart host push flag
KBCategory: kb3rdparty kbother kberrmsg kbfile
KBSubcategory: MailGWSMTP
Keywords : MailGWSMTP kb3rdparty kberrmsg kbfile kbother
Version : 2.10 3.00
Platform : MS-DOS


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Last reviewed: March 9, 1998
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