PC DirSync: Err Msg: Warning 8 Error Deleting File...

Last reviewed: June 5, 1996
Article ID: Q127752
The information in this article applies to:
  • Microsoft Mail for PC Networks, version 3.2

SYMPTOMS

During the T2 phase of directory synchronization (Dir-Sync) (when SRVMAIN -r runs), the following errors may be displayed:

   Error [115] Failure to read mail from <NULL>
   Warning[8]  Error deleting file: Network/postoffice/$SYSTEM
               Server processing failure

NOTE: There may be several 115 errors, but only one Warning 8.

CAUSE

SRVMAIN.EXE fails with the above error messages because of duplicate headers in the SYSTEM.MBG file. During automatic directory synchronization, a failure code is returned to NSDA, and the second phase of T2, which is SRVMAIN -t, is never spawned.

STATUS

Microsoft has confirmed this to be a problem in versions 3.2 and 3.2a of Microsoft Mail for PC Networks. This problem was corrected in SRVMAIN.EXE version 3.2.10. If you do not have version 3.2.10 (or later), You can find SRVUPD.EXE, a self-extracting file, on the following services:

  • Microsoft's World Wide Web Site on the Internet

          On the www.microsoft.com home page, click the Support icon.
          Click Knowledge Base, and select the product.
    
          Enter kbfile SRVUPD.EXE (size: 118556 bytes) 
                                 , and click GO!
          Open the article, and click the button to download the file.
    
    
  • Internet (anonymous FTP)

          ftp ftp.microsoft.com
          Change to the Softlib/Mslfiles folder.
          Get SRVUPD.EXE (size: 118556 bytes) 
    
  • The Microsoft Network

          On the Edit menu, click Go To, and then click Other Location.
          Type "mssupport" (without the quotation marks).
          Double-click the MS Software Library icon.
          Find the appropriate product area.
          Locate and Download SRVUPD.EXE.
    
  • Microsoft Download Service (MSDL)

          Dial (206) 936-6735 to connect to MSDL
          Download SRVUPD.EXE (size: 118556 bytes) 
    

For additional information about downloading, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online
               Services

MORE INFORMATION

Version 3.2.10 SRVMAIN.EXE ignores the duplicate headers and will complete the processing. The actual cause of duplicate headers in the SYSTEM.MBG is still being investigated.


Additional reference words: 3.20
KBCategory: kbenv kberrmsg kbbug3.20 kbbug3.20a kbfile
KBSubcategory: MailPCDirSync


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Last reviewed: June 5, 1996
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