MHS: Circular Routing Through the MHS Gateway

Last reviewed: October 20, 1997
Article ID: Q128432
3.00 MS-DOS kb3rdparty kbenv

The information in this article applies to:

  • Microsoft Mail Gateway to MHS, version 3.0

SYMPTOMS

Nondelivery messages do not leave the Mail Administrator program (ADMIN.EXE) MHS gateway queue. The messages never seem to be delivered and no error message is returned.

CAUSE

The "stuck" messages are actually messages from the postmaster at MSMail to the postmaster at MSMail. The gateway tried to deliver a message to POSTMAST@MSMAIL {NET1/PO1/POSTMASTER}. However, the user did not create a postmaster account; therefore, the External Mail program generated a nondelivery notice and sent it back to the originator, which was also POSTMAST@MSMAIL {NET1/PO1/POSTMASTER}. Since the mail was routing through the MHS gateway each cycle, the External Mail program never had the opportunity to consider it as a circular route.

RESOLUTION

Create a postmaster account on every postoffice that will be sending or receiving mail through the MHS gateway.


Additional reference words: 3.00
KBCategory: kb3rdparty kbenv
KBSubcategory: MailGWMHS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: October 20, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.