PC Ext: Err Msg: [004] Message Circular Route Detected

Last reviewed: June 5, 1996
Article ID: Q128627
The information in this article applies to:
  • Microsoft Mail for PC Networks, version 3.2

SYMPTOMS

The Mail External program (EXTERNAL.EXE) may record the following error in the SYSTEM.LOG:

   [004] Message circular route detected...

CAUSE

This happens under three conditions:

  1. When the postoffice where Mail is processed has a Network or Postoffice name that is nine characters in length.

  2. The Network name and Postoffice name match the first nine characters of the Network name and Postoffice name, respectively, in the hop trace.

  3. At least one / character has been processed in the hop trace.

STATUS

Microsoft has confirmed this to be a problem in version 3.2.16 of the Mail External program. This problem was corrected in version 3.2.17 of EXTERNAL.EXE. If you do not have version 3.2.17 (or later), you can download EXTUPD.EXE, a self-extracting file, on the following services:

  • Microsoft's World Wide Web Site on the Internet

          On the www.microsoft.com home page, click the Support icon.
          Click Knowledge Base, and select the product.
    
          Enter kbfile EXTUPD.EXE (size: 531665 bytes) 
                                 , and click GO!
          Open the article, and click the button to download the file.
    
    
  • Internet (anonymous FTP)

          ftp ftp.microsoft.com
          Change to the Softlib/Mslfiles folder.
          Get EXTUPD.EXE (size: 531665 bytes) 
    
  • The Microsoft Network

          On the Edit menu, click Go To, and then click Other Location.
          Type "mssupport" (without the quotation marks).
          Double-click the MS Software Library icon.
          Find the appropriate product area.
          Locate and Download EXTUPD.EXE.
    
  • Microsoft Download Service (MSDL)

          Dial (206) 936-6735 to connect to MSDL
          Download EXTUPD.EXE (size: 531665 bytes) 
    

For additional information about downloading, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online
               Services


Additional reference words: 3.20 circular routing
KBCategory: kbenv kberrmsg kbbug3.20
KBSubcategory: MailPCExt


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: June 5, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.