MHS: Err Msg: Inpost General I/O

Last reviewed: March 9, 1998
Article ID: Q130381
3.00 MS-DOS kbenv kbfile kbbug3.00 kbfix3.00 kbfix

The information in this article applies to:

  • Microsoft Mail Gateway to MHS, version 3.0

SYMPTOMS

Occasionally a nondelivery notification will not leave the MHS queue and will not be moved to the MHS directories. The following error may also appear in the MHSGATE.LOG file:

   INPOST General I/O

CAUSE

The buffer used to read in the TEXT FIPS field was not large enough.

RESOLUTION

Change the buffer to allow a maximum address size of 255 characters. For example, if it was previously defined as 84, set it to 259.

STATUS

Microsoft has confirmed this to be a problem in version 3.0 of Microsoft Mail Gateway to MHS. This problem is corrected in INPOST.EXE version 3.0.9. If you do not have version 3.0.9, you can download MHSINP.EXE, a self- extracting file, on the following services:

  • Microsoft's World Wide Web Site on the Internet

          On the www.microsoft.com home page, click the Support icon.
          Click Knowledge Base, and select the product.
    
          Enter kbfile MHSINP.EXE (size: 57245 bytes) 
                                 , and click GO!
          Open the article, and click the button to download the file.
    
    
  • Internet (anonymous FTP)

          ftp ftp.microsoft.com
          Change to the Softlib/Mslfiles folder.
          Get MHSINP.EXE (size: 57245 bytes) 
    
  • The Microsoft Network

          On the Edit menu, click Go To, and then click Other Location.
          Type "mssupport" (without the quotation marks).
          Double-click the MS Software Library icon.
          Find the appropriate product area.
          Locate and Download MHSINP.EXE.
    
  • Microsoft Download Service (MSDL)

          Dial (206) 936-6735 to connect to MSDL
          Download MHSINP.EXE (size: 57245 bytes) 
    

For additional information about downloading, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119591
   TITLE     : How to Obtain Microsoft Support Files from Online
               Services


Additional reference words: 3.00 stuck message
KBCategory: kbenv kbfile kbbug3.00 kbfix3.00 kbfix
KBSubcategory: MailGWMHS
Keywords : MailGWMHS kbbug3.00 kbenv kbfile kbfix kbfix3.00
Version : 3.00
Platform : MS-DOS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 9, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.