PC Mac: Err Msg: The Preference File Could Not Be Found...

Last reviewed: May 26, 1995
Article ID: Q130700
The information in this article applies to:
  • Microsoft Mail for PC Networks, Macintosh workstation, versions 3.2 and 3.2a

SYMPTOMS

In Microsoft Mail for PC Networks, Macintosh workstation, you can have difficulty connecting to the Maildata share on the server and/or logging into Mail. The error message displayed is:

   The Preference file could not be found. Where is your postoffice
   located?

CAUSE

The following are possible causes of the above error:

  1. The client is being launched for the first time, and the MS Mail/PC LANs Prefs cache file has not been created yet.

  2. The client has lost its connection to the Maildata share, and the connection needs to be re-established.

  3. The client's rights on the server are insufficient for it to function.

  4. The MS Mail/PC LANs Prefs file is corrupt.

RESOLUTION

  1. The MS Mail/PC LANs Prefs cache file will be created when you launch the Macintosh client.

    a. Launch the Mail client. The following message will be displayed:

             The Preference file could not be found. Where is your
             postoffice created?"
    
       b. Select Find PO.
    
       c. In the Where is the Mail Data Folder? dialog box, select Desktop.
          Select the Maildata server share found on the Desktop.
    
       d. A new dialog box will be displayed, Select Postoffice [postoffice
          name]?. Select the OK button. Type your user and password
          information.
    
       e. Select the OK button. Mail will launch.
    
    

  2. Verify that the PC Maildata share can be seen on the Macintosh Desktop. If you see the share icon, this confirms that the connection to the server has been made. However, if the PC Maildata share cannot be seen, perform the following steps to establish the connection:

    a. From the Apple menu, choose the Chooser. Then select AppleShare

          and the appropriate AppleTalk zone and Maildata server. Select the
          OK button.
    

    b. In the Connect to the File Server [server name] as: dialog box,

          select Registered User, and type the information for the name and
          password that will enable the workstation to login to the Maildata
          server. Select the OK button.
    

    c. In the Select Items You Want to Use: dialog box, select the

          Maildata share, and select the checkbox to enable the share to
          be opened at system startup.
    

    d. Accept the default of Save my Name Only, and select the OK button.

          The Maildata share icon should appear on the Desktop.
    

  3. If the Maildata share is mounted on the Desktop, and the Macintosh client still cannot find the postoffice, verify that you have sufficient rights to connect to the Maildata share. You should have the following rights to the Maildata subdirectory on the Mail for PC Networks server:

       Network Operating System            Rights Required for Macintosh Users
       -----------------------------------------------------------------------
       Windows NT                          Full Control
       LAN Manager                         All Permissions
       NetWare                             Read, Write, Create, Erase,
                                            Modify, and Filescan
    
    

  4. If the PC Mail postoffice can be seen and the access rights have been verified, the MS Mail/PC LANs Prefs file may be corrupt.

    a. To create a new one, drag the MS Mail/PC LANs Prefs file that is

          located in the System Folder to the Trash.
    

    b. Launch the Mail client. The following message will be displayed:

             The Preference file could not be found. Where is your
             postoffice created?"
    
       c. Select Find PO.
    
       d. In the Where is the Mail Data Folder? dialog box, select Desktop.
          Select the Maildata server share found on the Desktop.
    
       e. A new dialog box will be displayed, Select Postoffice [postoffice
          name]?. Select the OK button. Type your user and password
          information.
    
       f. Select the OK button. Mail will launch.
    


Additional reference words: 3.20 mac preferences error
KBCategory: kbsetup kbtshoot kberrmsg
KBSubcategory: MailPCMac


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: May 26, 1995
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.