Winsock Client Fail to Connect to Proxy Server if Disable TCP/IP

Last reviewed: January 22, 1998
Article ID: Q164675

The information in this article applies to:

  • Microsoft Proxy Server version 1.0

SYMPTOMS

When you use the Microsoft Winsock Proxy client with a client that uses both TCP/IP and IPX/SPX, the client may fail to connect to the Proxy Server if TCP/IP is disabled or bound to a modem.

CAUSE

The Winsock Proxy client always tries to use TCP/IP by default. If TCP/IP is not configured so that a TCP/IP connection can be made with the Proxy Server, the Winsock Proxy client will fail.

WORKAROUND

You can force Proxy Server to use IPX by using one of the following methods:

  • Remove the TCP/IP protocol from the client computer.
  • Edit the Mspclnt.ini file on the Proxy Server located in the \Msp\Clients directory, by default, and remove the following section from Mspclnt.ini:

          [Servers Ip Addresses]
          Name=[ProxyServerName]
    

    After you edit and save the file, open the Control Panel on the Winsock Proxy client computer. Open WSP Client and select Update Now.

Version           : WINNT: 1.0
Platform          : winnt
Hardware          : ALPHA x86
Issue type        : kbprb
Solution Type     : kbworkaround


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Last reviewed: January 22, 1998
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