Setup Error: Setup Cannot Update an Installation in Batch Mode

Last reviewed: December 16, 1996
Article ID: Q119275
The information in this article applies to:
  • Microsoft Office for Windows 95, version 7.0
  • Microsoft Office for Windows, versions 4.2, 4.3
  • Microsoft PowerPoint for Windows, versions 4.0, 4.0a
  • Microsoft Word for Windows, version 6.0
  • Microsoft Excel for Windows, version 5.0
  • Microsoft Access for Windows, version 2.0
  • Microsoft Project for Windows, version 4.0 ---------------------------------------------------------------------

SYMPTOMS

When you perform a "silent" installation (by using the SETUP /Q command) of any of the applications listed at the beginning of this article, the following error message is displayed

   Setup cannot update an installation in batch mode (/Q)

or

   Setup cannot update an installation interactively in quiet mode

followed by:

   Processing Top Level information failed

When you choose OK, the following message may be displayed

   <application> Setup was not completed successfully

where <application> is the name of the application for which you attempted to run a silent installation.

CAUSE

You can use the /Q switch only when you perform a new installation of an application. That is, you will receive the above error messages if you attempt to perform a silent mode installation of an application if that application is already installed on the workstation.

WORKAROUNDS

To avoid receiving these error messages, follow the appropriate procedure below.

Method 1: To perform a maintenance-mode installation such that you can

          manually select the components you want to add or remove, do the
          following:

          a. From the File menu in Program Manager, choose Run.

          b. In the Command Line box, type the following

                <x>:\setup

             where <x> is the drive containing the Setup program for the
             application from which you want to remove or to which you want
             to add components.

Method 2: To run a maintenance-mode installation based on a script:

          a. Run the Installation Maintenance program and select Remove All
             to remove the application from your system.

          b. Run Setup again using a script.

Method 3: To perform a new installation on a system which has one
          of the applications above already installed, do the following:

          a. Make a backup copy of the WIN.INI file.

          b. Open WIN.INI in a text editor.

          c. Search for the section that contains the word "ACME".
             The title of the section is [MS Setup (ACME) Table Files].

          d. This section contains a path to the SETUP.STF file for
             the application. Remark out the line that refers to
             SETUP.STF by placing a ";" (semi-colon) at the beginning
             of the line. Change the line:

             MSOFFICE.EXE@v4.3.0.1027(1033)=C:\MSOFFICE\SETUP\SETUP.STF

             -to-

             ;MSOFFICE.EXE@v4.3.0.1027(1033)=C:\MSOFFICE\setup\setup.stf

          e. Save the WIN.INI file and exit your text editor.

          f. Restart SETUP.


MORE INFORMATION

PowerPoint

Page 212 of the PowerPoint "User's Guide," version 4.0, lists the different types of installations with which you can use a "silent" installation: Typical, Complete/Custom, Laptop, and Workstation. If you run SETUP /Q, Setup uses whichever of these four types of installation is designated as the default in the SETUP.STF file.

A fifth type of installation, Installation Maintenance, is not included because it is designed to interact with the user to reconfigure the installed components. After you have installed PowerPoint 4.0, all subsequent installations on the same system are Installation Maintenance installations.

How the WIN.INI is Involved

When Setup is run, it looks in the [MS Setup (ACME) Table Files] section of the WIN.INI to see if there is a path to an STF. If it finds one, it enters the existing STF at the Maintenance Mode Root ID and you get maintenance mode setup. If it does not find an entry, or it can't find the resulting STF file, it creates a new STF and enters from the appropriate (non- maintenance) Root ID.

General Information

For more information about custom installation scripts, order Application Note WC1046, "How to Create a Custom Installation Script." For additional information, please see the following article(s) in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119357
   TITLE     : AppNote: "How to Create a Custom Installation Script"
               (WC1046)


KBCategory: kbsetup kbnetwork kberrmsg
KBSubcategory:

Additional reference words: 1.0 1.00 2.00 4.00 4.00a 4.20 4.30 5.00 6.00
quiet powerpoint powerpt office word excel acmsetup.exe maintenance mode



THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: December 16, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.