Setup Program Keeps Requesting Disk 2

Last reviewed: March 6, 1998
Article ID: Q119837

The information in this article applies to:

  • Microsoft Access 97 for Windows
  • Microsoft Access, version 2.0
  • Microsoft Access, version 7.0
  • Microsoft Bob for Windows, version 1.0
  • Microsoft Excel 97 for Windows
  • Microsoft Excel for Windows 95, version 7.0
  • Microsoft Excel for Windows, versions 5.0, 5.0c
  • Microsoft Office 97 for Windows
  • Microsoft Office for Windows 95, version 7.0
  • Microsoft Office for Windows, versions 4.0, 4.2, 4.3
  • Microsoft PowerPoint 97 for Windows
  • Microsoft PowerPoint for Windows 95, version 7.0
  • Microsoft PowerPoint for Windows, version 4.0
  • Microsoft Project 97 for Windows
  • Microsoft Project for Windows 95. version 4.1
  • Microsoft Project for Windows, version 4.0
  • Microsoft Visual FoxPro for Windows, version 3.0
  • Microsoft Word 97 for Windows
  • Microsoft Word for Windows 95, version 7.0
  • Microsoft Word for Windows, versions 6.0, 6.0a
  • Microsoft Works for Windows 95, version 4.0
  • Microsoft Works for Windows, version 3.0

SYMPTOMS

When you run the Setup program for one of the programs listed at the beginning of this article from floppy disks, after you remove Disk 1, insert Disk 2, and press ENTER, Setup repeatedly prompts you to insert Disk 2 again.

CAUSE

This behavior occurs if the information from the disk in the floppy disk drive (Disk 1) that has been cached in random access memory (RAM) is not flushed when you insert the next disk (Disk 2). The operating system, MS- DOS or Microsoft Windows, is still reading Disk 1, even though you have inserted Disk 2 in the drive.

WORKAROUNDS

To work around this behavior, use one of the following methods:

Method 1: MS-DOS DRIVPARM Solution

Use a text editor to open the CONFIG.SYS file. Place the DRIVPARM command in the CONFIG.SYS file with the following syntax:

   For a 1.44-MB A: drive      For a 1.44-MB B: drive
   --------------------------------------------------
   DRIVPARM=/d:0 /f:7          DRIVPARM=/d:1 /f:7


NOTE: You must reboot your computer after you modify the Config.sys file.

Method 2: Reset the Floppy Disk Drive

To reset the floppy drive, remove Setup Disk 2 and press ENTER. Insert the same disk in the drive again and press ENTER.

Method 3: Refresh the File List

With Setup Disk 2 in the floppy disk drive, do the following:

   Microsoft Windows 95
   --------------------

   a. On the Windows taskbar, click Start. Click Programs, and then
      click Windows Explorer.

   b. In Windows Explorer, click the drive that contains the Setup
      disk (for example, A) and press F5 to refresh the list of
      files displayed in the folder window. (If this doesn't work
      work, you may need to click another disk drive and then
      switch back to the drive that contains the Setup disk).

   c. Press ALT+TAB to switch back to the Setup program and continue
      installing the application.

   Microsoft Windows 3.x
   ---------------------

   a. Press ALT+TAB to switch to File Manager (or to Program
      Manager, and then run File Manager).

   b. Select the drive that contains the Setup disk (for example, A)
      and press F5 to update the directory window. (If this doesn't
      work, you may need to select another disk drive and then
      switch back to the drive that contains the Setup disk).

   c. Press ALT+TAB to switch back to the Setup program and continue
      installing the application.

Method 4: Reread the Tree at MS-DOS Prompt

If the options above do not correct the problem you can force the tree to be reread by using the following steps:

   a. Switch to or start an MS-DOS prompt.

   b. At the MS-DOS prompt, change to the installation drive.

   c. Press CTRL+C to clear the cache and force MS-DOS to reread
      the tree.

   d. Type exit to exit MS-DOS and return to Windows.

   e. Press ALT+TAB (if necessary) to return to the Setup program
      and continue installing the application.

   Note: You may have to repeat this process between each disk change.

MORE INFORMATION

For more information, please see the following article(s) in the Microsoft Knowledge Base:

   ARTICLE-ID: Q79207
   TITLE     : WinWord Setup Fails on Disk 2; DRIVPARM Solution

   ARTICLE-ID: Q124970
   TITLE     : Troubleshooting DMF Issues


Additional query words: 1.00 1.10 2.00 3.00 4.00 4.10 4.20 4.30 5.00
5.00c 6.00 6.00a 7.00 8.00 97 dmf garbage continually repeatedly macppt
winppt
Keywords : offwin xlwin kbsetup kbtshoot
Version : windows:1.0,1.1,2.0,3.00
Platform : WINDOWS
Hardware : x86
Issue type : kbprb


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 6, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.