Troubleshooting DMF Issues

Last reviewed: January 28, 1998
Article ID: Q124970
The information in this article applies to:
  • Microsoft Office 97 for Windows
  • Microsoft Office for Windows 95, version 7.0, 7.0a, 7.0b
  • Microsoft Office for Windows, versions 4.2c, 4.3c
  • Microsoft Works for Windows 95, version 4.0

SUMMARY

This article is a checklist for troubleshooting distribution media format (DMF) setup issues. Some of the issues mentioned here are covered elsewhere in greater depth. Each section lists where you can find more information about a particular subject. The following topics are covered:

  • Damaged Disks
  • Maintenance Mode Setup
  • NT Version 3.1 Compatibility
  • Disk 2 Read Error--Setup Requests Disk 2 Again
  • Unable to decompress/read from .CAB file
  • Floptical Drives Can't Read DMF Disks
  • Older Gateway Handbooks Can't Read DMF Disks
  • Error Using DMF Disks on Power Mac Running SoftWindows
  • Error Using DMF Disks Under OS/2
  • Can't Back up DMF Disks to Floppy Disks
  • Virus Symptoms

DAMAGED DISKS

  1. When you start your computer, bypass the configuration files by pressing F5 when you get the "Starting MS-DOS" prompt.

  2. To make a directory called "disks," type the following at the MS-DOS prompt

          md \disks
    

    and change to that directory by typing "cd \disks" (without the quotation marks).

  3. Copy the Extract.exe program from Microsoft Office disk 1. Note that Extract.exe is on disk 2 for Microsoft Office 97.

  4. Put the disk causing the problem in the drive and type the following

          extract /e <drive>:\msoff<x>.cab
    

    where <drive> is the floppy disk drive containing the Office disk and <x> is the number of the disk.

    NOTE: The Extract program may ask for additional disks. This behavior is normal.

If the files are not successfully extracted, the problem is probably not configuration related and may be related to a damaged disk or a hardware problem.

To obtain replacement Office disks, call the Microsoft Order Desk at (800) 360-7561 and request a replacement for the damaged Microsoft Office disk. If you are outside the United States, contact the Microsoft subsidiary for your area. To locate your subsidiary, see the Microsoft World Wide Offices Web site at:

   http://www.microsoft.com/worldwide/default.htm

MAINTENANCE MODE SETUP

When you run Setup using the icon in Program Manager (Maintenance Mode Setup), you may receive errors such as "Could not read file" when you insert disks. This happens when Word was installed on the hard disk drive with standard disks and you use DMF disks when prompted by Maintenance Mode Setup. The Setup program on the hard drive cannot read the distribution media format (DMF) disks.

For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q121802
   TITLE     : "Could Not Read From File..." Running Maintenance Mode Setup

NT VERSION 3.1 COMPATIBILITY

Microsoft Windows NT version 3.1 is not able to read DMF disks. A service pack is available to correct this problem.

Workarounds

To correct this problem, do any of the following:

Method 1: Update your operating system by updating Floppy.sys or installing

          Microsoft Windows NT Service Pack 3.

Method 2: Contact Microsoft Product Support Services to obtain the latest
          system files.

Method 3: Contact Microsoft Sales Information Center at (800) 426-9400 for
          standard (non-DMF) disks.

DISK 2 READ ERROR - SETUP REQUESTS DISK 2 AGAIN

Symptoms of this problem include:

  • When you type DIR to display a directory of a DMF disk or a standard floppy disk at an MS-DOS prompt, garbage characters appear on the screen.
  • When you insert a different disk in the floppy disk drive, for example when you are running Setup, the new disk is not successfully read. This can cause Setup to request Disk 2 again, after you have already inserted Disk 2.

Cause

This can happen in any of the following scenarios:

   Case 1: The floppy disk drive is not reading the disks properly.

   If change-line support is not working properly, accessing a distribution
   media format (DMF) floppy disk fails.

   Change-line support informs MS-DOS when a disk and/or the format of a
   disk has changed. If MS-DOS determines the format of the first disk but
   does not realize that the formatting of the second disk is different,
   the second disk cannot be read.

   Case 2: Disk caching software isn't releasing the contents of the
           previous disk.

   Case 3: A virus has infected the hard drive or disks.

Workarounds

To work around this problem, use the method below for case that applies to you:

Case 1 (Disk drive reads incorrectly)

Method 1: Add the MS-DOS DRIVPARM command to your Config.sys file.

          Place the DRIVPARM command in the Config.sys with appropriate
          syntax for your floppy disk drive.

          For a 1.44-MB A drive      For a 1.44-MB B drive
          --------------------------------------------------

          DRIVPARM=/d:0 /f:7         DRIVPARM=/d:1 /f:7

For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q79207
   TITLE     : WinWord Setup Fails on Disk 2; Cannot Do DIR on 2nd Disk

Method 2: Remove Disk 2 from your floppy disk drive and press ENTER. Then
          reinsert Disk 2, and press ENTER again.

Method 3: If Setup continues to request Disk 2, even though Disk 2 is in
          the floppy disk drive, do the following:

          a. Press ALT+TAB to switch to File Manager (or to Program
             Manager, and then run File Manager).

          b. Select the drive icon that contains Disk 2, and press F5 to
             force a refresh.

          c. Press ALT+TAB again to switch back to Setup and continue.

For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q119837
   TITLE     : Setup Program Keeps Requesting Disk 2

Case 2 (Disk Caching software)

Disable the disk caching software. Commonly-used disk caching software includes the following products:

  • Super PC-Kwik
  • Lucid Lightning
  • Helix Netroom
  • The Cloaked DiskCache

For additional information, query on the specific product name in the Microsoft Knowledge Base.

Case 3 (Virus)

While this is an unlikely possibility, Microsoft has received reports that certain viruses will cause the Setup program not to recognize disk 2.

Scan the hard drive, using MS-DOS software or a third-party virus detector. If a virus is found, remove the virus before reinstalling the software.

Microsoft has rigorous quality control measures to insure that viruses are not on disks that we ship. The Setup disks for the programs listed above are distributed virus-free.

For additional information, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q105212
   TITLE     : Office: Setup Problems May Indicate that System Has Virus

   ARTICLE-ID: Q80520
   TITLE     : How Microsoft Ensures Virus-Free Software

UNABLE TO DECOMPRESS/READ FROM .CAB FILE

You may receive an error that setup is unable to decompress or read from a cabinet file (such as Word2.cab or Msoff2.cab) when running setup in maintenance mode from your hard drive. If you receive this error running setup in maintenance mode, exit setup and run setup from the installation disk #1 instead.

Another possible cause of this error during an installation could be the use of third-party disk caching software.

To work around this problem, disable the disk caching software and proceed with setup. Commonly-used disk caching software includes the following products:

  • Super PC-Kwik
  • Lucid Lightning
  • Helix Netroom
  • The Cloaked DiskCache

FLOPTICAL DRIVES CAN'T READ DMF DISKS

Floptical (and other SCSI floppy drives) cannot read DMF disks because the drive hardware has fixed assumptions about standard floppy formats.

Workaround

Contact Microsoft Sales Information Center at (800) 426-9400 to obtain standard (non-DMF) disks.

OLDER GATEWAY HANDBOOKS CAN'T READ DMF DISKS

Workaround

Older Gateway Handbook machines have Flash BIOS which needs to be updated.

Method 1: Contact Gateway for a BIOS update.

Method 2: Contact Microsoft Sales Information Center at (800) 426-9400 and

          order standard (non-DMF) disks.

ERROR USING DMF DISKS ON POWER MAC RUNNING SOFTWINDOWS

When you run the Setup program for one of the applications listed above on an Apple Power Macintosh computer running SoftWindows, your computer may not read the Setup disks. The Setup program may fail to recognize disk 2 and will continue to prompt you for disk 2 after you've inserted it in the disk drive.

For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q122279
   TITLE     : Error Installing Application on Power Mac Running
               SoftWindows

Error Using DMF Disks Under OS/2

Setup of any of the products listed above was not tested on OS/2 or OS/2 Warp Version 3. For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q122280
   TITLE     : Error Running Setup from DMF Disks Under OS/2

CAN'T BACKUP DMF DISKS TO FLOPPIES

DMF is a new disk format which allows more information to fit on each disk. Because of this format, disks cannot be backed up. In the past, making backup disks was a necessary part of installation. Now, better hardware and software means backup disks are seldom, if ever, needed.

If you do want backup disks, you may order them by calling Microsoft Sales Information Center at (800) 426-9400. There is a small handling charge of $5.00, which is less than the price of new, blank disks.

VIRUS SYMPTOMS

Any of the symptoms listed above may also be symptoms of a virus. If you suspect that a virus is present on your computer, scan the hard drive and disks with a virus detector. If a virus is found, remove the virus before running Setup again.

Microsoft has rigorous quality control measures to insure that viruses are not on disks that we ship. The Setup disks for the applications listed above are distributed virus-free in sealed clear plastic envelopes that display a message about the Microsoft software license agreement. If disks are purchased in any other type of package, they should not be used.

The following viruses are known to cause problems when Setup is run from DMF disks:

   antiEXE  NOINT  Junkie  A-Dign  B1  V-Sign RIPPER

For additional information, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q105212
   TITLE     : Office: Setup Problems May Indicate that System Has Virus


Additional reference words: 1.10 2.00 3.00 4.00 4.20c 4.30c 7.00 7.00a
7.00b tshoot DMF bob bad PowerPC "Power PC" w_bob emsdmf3.2 emsdmf trouble
shoot tshoot
Keywords : offwin offwinsetup kbsetup kbtshoot
Version : 1.10 2.00 3.00
Platform : WINDOWS


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Last reviewed: January 28, 1998
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