Web Post Acceptor May Not Work with DPA Installed on Web Server

Last reviewed: February 10, 1998
Article ID: Q171337
The information in this article applies to:

- Microsoft Internet Explorer, version 3.02 - Microsoft Commercial Internet System (MCIS), version 1.0 - Microsoft Site Server, version 2.0

  - Microsoft Web Posting Acceptor

SYMPTOMS

When you use the Microsoft Web Posting Acceptor in conjunction with the Microsoft HTTP Post RFC1867 Update for Microsoft Internet Explorer, version 3.02, and the Microsoft Distributed Password Authentication (DPA) engine from Microsoft Commercial Internet System (MCIS), one of the following error messages may appear:

   The parameter is incorrect.

   -OR-

   The Web Server is not responding or returned an unrecognized response.

CAUSE

The "Parameter is incorrect" error message indicates that the Microsoft HTTP Post RFC1867 Update cannot read the Postinfo.asp file. The Microsoft Web Posting Acceptor works for the first post when the Uploadx.asp file is loaded. The Microsoft HTTP Post RFC1867 Update reuses the connection that was authenticated with DPA on loading of the Uploadx.asp file. On a re- post, the Microsoft HTTP Post RFC1867 Update opens a new connection, attempting to authenticate the user, and gets an HTTP redirect to the Membership Broker System (MBS) troubleshooting page because the authentication failed. Internet Explorer then displays an error message saying, "The Web Server is not responding or returned an unrecognized response."

STATUS

Microsoft has confirmed this to be a problem with Microsoft Commercial Internet System version 1.0. A supported fix is now available, but has not been fully regression- tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Additional query words: UPLOAD WEBPOST POST
Version : 1.00
Platform : WINDOWS
Issue type : kbbug
Solution Type : kbfix


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 10, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.