SMS Administrator Unable To Retrieve Machine List

Last reviewed: March 20, 1998
Article ID: Q125487

The information in this article applies to:
  • Microsoft Systems Management Server versions 1.0, 1.1, and 1.2

SYMPTOMS

After dumping the Systems Management Server database and transaction log to a dump device and then restoring it to a different database and log device, either on the same SQL Server or a different one, the SMS Administrator cannot retrieve the list of machines in a domain and the following errors appear in the Data Loader log file, DATALODR.LOG:

   CMachine::FindMachine - Searching for matching Identification group info

   CMachine::FindMachine - Query Execution failed

These errors also appear in the Hierarchy Manager log file, HMAN.LOG:

   {818} ERROR SQL: General SQL Server error:
                    Check messages from the SQL Server.

   {825} INFO SQL: Can't allocate space for object 'Syslogs' in database
                  'xxx' because the 'logsegment' segment is full. If you
                  ran out of space in Syslogs, dump the transaction log.
                  Otherwise, use ALTER DATABASE or sp_extendsegment to
                  increase the size of the segment.

   (where xxx is the SMS database name)

CAUSE

These errors occur because the Transaction Log for the SMS Database is full and SQL Server can no longer log transactions to it. When SMS originally created the database it enables the Trunc. Log on Chkpt. option. When the database is dumped and then restored to a new device, that option is not set by default, therefore the Transaction Log is never truncated and fills up after a while.

RESOLUTION

  1. Dump the Transaction log with the No Log option.

        
    
2. Set the option Trunc. Log on Chkpt. for the SMS database.

For more information, refer to the "Microsoft SQL Administrator User's Guide" and the "Microsoft SQL Server Troubleshooting Guide."


Additional query words: sms prodsms
SMS_HIERARCHY_MANAGER SMS_INVENTORY_DATA_LOADER
Keywords : smsdatabase smshierman smsinv kbenv
Version : 1.0 1.1 1.2
Platform : WINDOWS
Issue type : kberrmsg


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 20, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.