SNA Server 2.11 CD missing Rally-compatible PC Support API

Last reviewed: April 24, 1996
Article ID: Q138861
The information in this article applies to:
  • Microsoft SNA Server for Windows NT, version 2.11

SYMPTOMS

The SNA Server 2.11 readme file includes the following section, though the alternate DLL files mentioned are not included on the 2.11 product CD:

   C.4. EHNAPPC.DLL Compatibility with Attachmate RALLY! and PC Support

   IBM PC Support and Attachmate RALLY! are examples of applications that
   depend on the static ordinal numbering of entry points in EHNAPPC.DLL.
   Various vendors' implementations of EHNAPPC.DLL differ in this static
   numbering, and many applications use dynamic linking by entry point name
   to avoid this problem.

   The version installed by default with the SNA Client is compatible
   with IBM CA/400. However, this version is not compatible with RALLY!,
   and will cause this application to fail via general protection failure
   or a pop-up message with the text "Assertion failed." SNA Server
   provides alternate versions of EHNAPPC.DLL and EHNRTRW.DLL which are
   compatible with the NetSoft EHNAPPC.DLL, for use with these
   applications.

   The alternate DLLs are found in the CD-ROM directory
   \CLIENTS\WIN3X\EHNNS\ and must be copied into the Windows system
   directory if you encounter this error.

CAUSE

The alternate DLL files were inadvertently left off the SNA Server 2.11 CD.

RESOLUTION

The alternate DLL files can be found in Rally.zip, located on the following electronic locations:

  • FTP.MICROSOFT.COM, in \bussys\winnt\sna-public\rally.

STATUS

Microsoft has confirmed this to be a problem in SNA Server for Windows NT. This problem was corrected in the latest SNA Server for Windows NT, 2.11 U.S. Service Pack. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


KBCategory: kbnetwork kb3rdparty kbbug2.11
KBSubcategory: ntnetserv
Additional reference words: 2.11 prodsna


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: April 24, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.