5250 Applet Causes GP Fault when Entering AS/400 Host Editor

Last reviewed: June 18, 1996
Article ID: Q140266
The information in this article applies to:
  • Microsoft SNA Server for Windows NT, versions 2.1 and 2.11

SYMPTOMS

When you attempt to work with AS/400 electronic mail or documents, the SNA Server 2.1 and 2.11 5250 applets can encounter a General Protection Fault (GPF) or application exception error. This problem occurs with the Windows 3.x and Windows NT 5250 applets on SNA Server 2.1, and the Windows NT 5250 applet on SNA Server 2.11.

CAUSE

The problem is caused by the AS/400 interfacing with the applet as if it is a host terminal. Therefore, when you try to work with mail or documents, the AS/400 tries to use the Host Editor (as opposed to PC Text Assist or the Adapted word processor). The 5250 applet does not support this mode.

RESOLUTION

An update to the 5250 applet is available which prevents the application exception from occurring. Instead, a blank screen appears now at which point you must press the F3-key to return to the previous AS/400 screen. This causes an internal error on the document you are trying to access.

To avoid this problem, you need to configure your AS/400 OfficeVision environment to default to the Adapted word processor instead of PC Text Assist. In addition to this change, an update to the 5250 applet is necessary, since the AS/400 still tries to use the Host editor, but if that fails, then drops to Adapted.

Microsoft has updated the following files to correct this problem:

   Windows NT:  <snaroot>\SYSTEM\WIN5250.EXE
                <snaroot>\SYSTEM\SNASRV.EXE
   Windows 3.x: <sna.win>\WIN5250.EXE
                <sna.win>\SNASRV.EXE

STATUS

Microsoft has confirmed this to be a problem in SNA Server for Windows NT. This problem was corrected in the latest SNA Server for Windows NT, 2.11 U.S. Service Pack. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


KBCategory: kbnetwork kbbug2.10 kbbug2.11
KBSubcategory: ntnetserv
Additional reference words: prodsna 2.10 2.11 rumba office vision


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: June 18, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.