The information in this article applies to:
- Microsoft SNA Server for Windows NT, versions 2.0, 2.1, 2.11, and
2.11 Service Pack 1
SYMPTOMS
When you install the Attachmate SDLC card and the Attachmate Advanced SDLC
card using the link support included in SNA Server 2.0, 2.1, 2.11, or 2.11
Service Pack 1, the link support does not function properly for computers
that have an ISA/PCI bus configuration. The problem may manifest itself in
the following ways:
- Link Service will start, but the connection defined for it in SNA
Server Admin will not shift from Inactive.
- Link Service will start, the connection will shift to a Pending
state, but if a Level 2 trace is taken on the Link Service, the trace
will show no frames sent or received.
- Link Service will start, but modem does not dial or respond to dial
commands. The modem status lights will not show any change.
- Link Service will not start.
CAUSE
The above symptoms may be due to an incompatible INF file. If the Link
Service was installed with an improper INF file, the card name will not
show in the drop down box labeled Card Type of the Link Service Setup
dialog box.
WORKAROUND
Attachmate provides replacement driver and INF files on the following
gopher site:
gopher://gopher.attachmate.com
Use your web browser to connect to this site. Go to the Hardware section,
and download the following files:
P7200.EXE (Attachmate SDLC Card)
P7500.EXE (Attachmate Advanced SDLC Card)
The files are self extracting executables. After you extract the files,
follow the steps below to replace the INF file on your SNA Server (if you
are using a version previous to 2.11, you may also need newer drivers):
- Remove the link service using SNA Server Setup.
- Run File Manager.
- Search the SNA root directory and all subdirectories for a file named
Advsdlc.inf (for the Attachmate Advanced SDLC card), or Atmsdlc.inf (for
the Attachmate SDLC card).
- Replace the file with the corresponding file from the download from
the Attachmate gopher site.
- Add the Link Service again. The name of the card should appear in the
pull down box at this time.
The third-party products are manufactured by Attachmate Corporation, a
vendor independent of Microsoft; we make no warranty, implied or otherwise,
regarding this product's performance or reliability.
MORE INFORMATION
You can detect the problem by using the following steps:
- Ensure that the card is installed correctly by verifying that no IRQ,
DMA (in the case of the Attachmate SDLC card), I/O address, or Shared
Memory Address (in the case of the Attachmate Advanced SDLC card)
conflicts exist. Also, verify that Plug and Play is disabled, as well as
any other settings that may conflict with Microsoft Windows NT.
- Run the SNA Server Setup program.
- Click the Continue button, and then click the Links button.
- If the Attachmate link service has been installed already, click
the Attachmate link service, and then click the Configure button.
Otherwise select the Add... button, and select the appropriate
Attachmate SDLC link service. Ensure that the SNA Server media is
accessible in case the Setup program asks for the installation path.
- After you configure the card specific parameters, click Continue
until you reach the Link Service Setup window.
- Select the Card Type list. If no card appears on the list, you probably
have the incorrect INF file.
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