RUI_TERM Hangs on Inactive LU After Session Cycle

Last reviewed: April 17, 1997
Article ID: Q160450
The information in this article applies to:
  • Microsoft SNA Server, versions 2.0, 2.1, and 2.11

SYMPTOMS

When you are calling RUI_TERM on an inactive LUA LU, the RUI_TERM may stop responding and never complete. This was observed on the second time through the following call sequence:

   WinRUIStartup
    <- OK
   RUI_INIT ->
    <- RUI_INIT error (LU inactive)
   RUI_TERM ->
    <- LUA_OK
   WinRUICleanup
    <- Error 1 (WLUASYSNOTREADY)

The first time through, the RUI_TERM completes without a problem. However, when executing this loop a second time, the RUI_TERM never completes.

NOTE: If the connection supporting the LUA LU is not "Active", or if SNA Server has not received an ACTLU for this LU, the SNA Server 2.x Administrator program or SNA Server 3.0 Manager will display the LU as "Inactive."

CAUSE

This is caused by a problem in the SNA Server RUI DLL (Winrui32.dll for Windows NT or Windows 95 clients, or Winrui.dll for Windows 3.x clients).

RESOLUTION

An update is available to correct this problem. This fix is already included in SNA Server 3.0.

STATUS

Microsoft has confirmed this to be a problem in SNA Server versions 2.0, 2.1, and 2.11. This problem was corrected in the latest Microsoft SNA Server 2.11 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


Additional query words: prodsna
Keywords : kbfix2.11.sp2 kbnetwork kbprg snalua snaprog kbbuglist
Version : 2.0 2.1 2.11
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: April 17, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.