Print Session Hangs in Spooling Status and Printing for Session

Last reviewed: March 19, 1998
Article ID: Q169854

The information in this article applies to:

  • Microsoft SNA Server versions 3.0 and 3.0 Service Pack 1 (SP1)

SYMPTOMS

An SNA Server 3270 Print Session gets stuck in Spooling status forever and all printing for that print session stops. You have to stop the SNA Print Service and restart in order to recover.

CAUSE

The problem happens when print sessions are stopped while print jobs are still being spooled and other print sessions are still running. The Spooling status bit is never unset (because of a bug in the code that was supposed to do this), and SNA Manager will display this status in preference to any other status bit which may be set (closing, inactive and so on). Therefore, the status bar sits at Spooling and never gets updated with the real status.

STATUS

Microsoft has confirmed this to be a problem in SNA Server 3.0 and 3.0 sp1. This problem was corrected in the latest SNA Server version 3.0 U.S. Service Pack. For information on obtaining this Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K

MORE INFORMATION

With the fix applied, printing status is set to idle whenever SNA Print Service ends the current print job.

Keywords          : prodsna snaprintservice kbfix3.00.sp2 kbnetwork kbbuglist
Version           : 3.0
Platform          : winnt
Issue type        : kbbug
Solution Type     : kbfix


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 19, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.