Changing Security Options on MIPS System Results in 4116 Error

Last reviewed: November 6, 1997
Article ID: Q170390
The information in this article applies to:
  • Microsoft SNA Server version 2.11 (all versions)

SYMPTOMS

The following error is displayed when trying to exit the SNA Server Admin Security options under SNA Server 2.11 when it is running on a MIPS system.

   Error: 4116

   An error occurred at the server in attempting to process your request. 
   Your changes may not have been applied.

This problem occurs on both the Japanese and U.S. versions of SNA Server 2.11 when running on a MIPS system.

MORE INFORMATION

To reproduce this problem, follow these steps:

  1. Log on to Windows NT on MIPS system using the Administrator account.
2. Install SNA Server and start SNA Server Admin. 3. Click Permissions on the Security menu in SNA Server Admin. 4. Click OK after adding some users or groups, or only choose OK. 5. The error 4116 popup message is displayed.

  - or -

  • Log on to Windows NT on MIPS system using the Administrator account. 2. Install SNA Server and start SNA Server Admin. 3. Click Owner on the Security menu in SNA Server Admin. 4. Click the Take Ownership button. 5. The error 4116 popup message is displayed.

    CAUSE

    This problem is caused because of a structure member alignment problem with SNA Server 2.11 when running on a MIPS system. Because the structure member is passed across the network, it could not be aligned correctly. The result is that a new security structure is allocated and the misaligned member structure is copied into it before the Windows NT security call is made. This results in the 4116 error.

     
    

    RESOLUTION

    The security component of the SnaBase service has been updated to correct this problem. In addition, ACL caching is no longer done when SNA Server 2.11 is used on a MIPS system.

    STATUS

    Microsoft has confirmed this to be a problem in SNA Server version 2.11.

    A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Product Support Services for more information.


  • Additional query words:
    Keywords : prodsna snaadmin kbbuglist kbnetwork
    Version : 2.11
    Platform : winnt


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    Last reviewed: November 6, 1997
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