TN3270 Client Hangs with Keyboard Locked on Some Host Screens

Last reviewed: February 3, 1998
Article ID: Q175384
The information in this article applies to:
  • Microsoft SNA Server, versions 3.0, 3.0 SP1, 3.0 SP2

SYMPTOMS

If a TN3270 client is connecting through the SNA Server TN3270 Service, on certain host screens, the TN3270 client keyboard remains locked in an XCLOCK state. A native 3270 client does not have this problem.

This problem occurs with the TN3270 Service included with Microsoft SNA Server version 3.0, 3.0 Service Pack 1 (SP1), and 3.0 Service Pack 2 (SP2).

CAUSE

The client keyboard lock occurs when the host application sends a 3270 message to the client and indicates an End Bracket (EB), but the WCC field in the 3270 message does not unlock the keyboard. (That is, bit 6 in the WCC field is set to "0" which means that the keyboard is locked.) Because a TN3270 client never receives the SNA Request/Response Header (RH), it is not aware of the EB indicator and does not determine that the keyboard should be unlocked. Because the host application does not unlock the keyboard properly in the WCC byte, the TN3270 emulator's keyboard remains locked.

This problem does not occur with a native 3270 emulator because it receives the SNA RH, and unlocks the keyboard when it receives an EB, even if the 3270 WCC field does not unlock the keyboard.

WORKAROUND

The only workaround available for this problem is to modify the host application so that it properly sets the WCC bit 6 to unlock the keyboard on host screens which exhibit the problem.

RESOLUTION

An update to the SNA Server TN3270 Service is available from Microsoft to correct this problem. With the update TN3servr.exe file applied, the TN3270 server monitors for the EB indicator on host messages, and if it is set, will automatically set the WCC Bit 6 (keyboard state) to 1 to notify the TN3270 client that the keyboard should be unlocked.

STATUS

Microsoft has confirmed this to be a problem in SNA Server 3.0, 3.0 SP1, and 3.0 Service Pack 2. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Additional query words: prodsna snatn3270 xclock tn3270e
Keywords : kbbug3.00 kbbug3.00.sp1 prodsna snatn3270 kbbug3.00.sp2
Version : Windows:3.0,3.0sp1,3.0sp2
Platform : WINDOWS
Hardware : ALPHA x86
Issue type : kbbug
Solution Type : kbfix


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Last reviewed: February 3, 1998
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