LUA Program Hangs After Receiving Exception Request (EXR)

Last reviewed: February 3, 1998
Article ID: Q178256
The information in this article applies to:
  • Microsoft SNA Server, versions 3.0, 3.0SP1, 3.0SP2

SYMPTOMS

An SNA Server LUA application may hang indefinately after receiving an exception request (EXR) message on a session, which SNA Server sends to the client after it has detected a bad RU in an outbound message from the host.

CAUSE

If the host sends a bad RU on a session, the SNA Server changes the message to Exception Request type (EXR) before sending it to the LUA application. However, SNA Server was failing to set the End Chain (EC) indicator on the EXR message, causing the LUA application to hang indefinately waiting for EC to be received.

STATUS

Obtain the following fix or wait for the next SNA Server 3.0 service pack.

This fix should have the following timestamp:

   10/30/97  7:06a    437,440  <snaroot>\system\snaservr.exe
   10/30/97  7:06a    412,644  <ntroot>\symbols\exe\snaservr.dbg
   10/30/97  7:07a    824,048  <snaroot>\system\trcservr.exe
   10/30/97  7:07a    751,412  <ntroot>\symbols\exe\trcservr.exe
   
NOTE: SNA Server 3.0 Service Pack 2 should be applied prior to applying this fix.

Microsoft has confirmed this to be a problem in SNA Server 3.0 (including SP1 and SP2). A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Keywords          : kbbug3.00 kbbug3.00.sp1 prodsna snalua snaprog kbbug3.00.sp2
Version           : WINDOWS:3.0,3.0SP1,3.0SP2
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix kbpatch


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Last reviewed: February 3, 1998
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