Perfmon Trap or Winlogon STOP C000021A When Running Perfmon

Last reviewed: March 10, 1998
Article ID: Q180054
The information in this article applies to:
  • Microsoft SNA Server version 4.0

SYMPTOMS

When you start the Windows NT Server Performance Monitor locally on a computer running SNA Server and you pressing the "+" key (which loads the extension Performance Monitor DLLs, including snaperf.dll), the following errors may occur:

  • All Performance Monitor objects and counters are blank, even SNA Server ones. When you start Performance Monitor under a debugger, it indicates that the Performance Monitor heap is corrupted. This causes Performance Monitor (Perfmon.exe) to encounter an access violation (0xC0000005).
  • When you start Performance Monitor on another system, focus on the computer running SNA Server 4.0, and press the "+" key, an access violation (0xC0000005) occurs in Winlogon.exe, leading to a STOP 0xC000021A.
  • The following log entry may appear in the <ntroot>\drwtsn32.log file:

          Application exception occurred:
          App: exe\winlogon.dbg (<process ID>)
          Exception number: c0000005 (access violation)
          [...]
          function: RtlAllocateHeap
          [...]
    

NOTE: A similar access violation problem may occur with SNA Server 3.0, though this problem is fixed when applying 3.0 Service Pack 2.

CAUSE

This problem is caused by a regression introduced in SNA Server 4.0 when support for multiple instances of the SNA Server service on a single computer was added. However, multiple SNA Server services do not need to be configured in order to encounter this problem.

WORKAROUND

Do not run Windows NT Performance Monitor against SNA Server.

STATUS

Microsoft has confirmed this to be a problem in SNA Server version 4.0 A supported fix for SNA Server 4.0 is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

MORE INFORMATION

For additional information on the access violation problem may with SNA Server 3.0, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q169488
   TITLE     : Errors When Performance Monitoring SNA Server
Keywords          : prodsna kbbug4.00 kbfix4.00.sp1
Version           : WINDOWS:4.0
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: March 10, 1998
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