SNA Server Stops After Logging Event 684 and 685.

Last reviewed: February 9, 1998
Article ID: Q180619
The information in this article applies to:
  • Microsoft SNA Server, versions 3.0, 3.0SP1, 3.0SP2

SYMPTOMS

The SNA Server service may stop unexpectedly and log the following Event ID in the Windows NT Event Viewer Application log:

   Event ID: 685
   Source:   SNA Server
   Description: An attempt was made to extend a buffer pool, but 
   the related pool had reached its maximum size. The affected component 
   is terminating, and an audit of the buffer pools just before 
   termination is attached

   <the data will indicate a large number of trusted headers owned by the
    SNASERVR process >

This event will be preceded by numerous Event 684 messages, which indicate that the SNA Server's trusted header use is growing by about 150 per minute until the maximum trusted header pool is reached (of 100,000). When this occurs, SNA Server stops.

This problem coincides with the use of an APPC application that uses the DISPLAY API function to retrieve all LU6.2 configuration and state information.

CAUSE

When receiving an APPC DISPLAY request from an APPC application to retrieve LU6.2 information, SNA Server occasionally allocates an extra trusted header it doesn't actually use and then fails to free it.

STATUS

Microsoft has confirmed this to be a problem in SNA Server versions 3.0, 3.0 SP1 and 3.0 SP2. This problem is fixed in SNA 4.0.

A supported fix is now available for SNA 3.0, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Product Support Services for more information.

Keywords          : kbbug3.00 kbbug3.00.sp1 snaappc snaserverservice kbbug3.00.sp2
Version           : WINDOWS:3.0,3.0SP1,3.0SP2
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 9, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.