Print Server May Experience Occasional Performance Degradation

Last reviewed: February 11, 1998
Article ID: Q180863
The information in this article applies to:
  • Microsoft SNA Server, versions 3.0, 3.0 SP1, 3.0 SP2, 4.0

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

When a print job is sent to a printer attached to a workstation that has been unplugged from the network or has encountered a blue screen STOP screen, all SNA Server printer sessions start printing very slowly (for example, five minutes per page) until the workstation has recovered.

CAUSE

SNA Server Print Server is not optimizing the use of threads for the number of print sessions that are running.

WORKAROUND

If the print job that caused the problem (that is, the print job on the workstation that had previously encountered a blue screen STOP message) is deleted on the host side, printing for the other print sessions will resume normally.

STATUS

Microsoft has confirmed this to be a problem in SNA Server versions 3.0 and 3.0 SP1. To resolve this problem, you must upgrade to SNA Server version 3.0 SP2 and apply the hotfix listed below, under SNA Server version 3.0 SP2.

Microsoft has confirmed this to be a problem in SNA Server version 3.0 SP2. A supported fix is now available, but has not been fully regression- tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Microsoft has confirmed this to be a problem in SNA Server version 4.0. A supported fix is now available, but has not been fully regression- tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

MORE INFORMATION

With the hotfix applied, a registry entry can be used to define the number of print sessions that are going to be used on the SNA Print Service. Do the following:

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

  1. Apply the hotfix.
2. Start the Windows NT Registry Editor (Regedt32.exe) and find the
   following key:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
      \Services\SnaPrint\Parameters: REG_SZ: <value>

where value is set to the number of print sessions used on the SNA Print Service.

When this registry entry is defined, the print service will optimize its use of threads for the number of print sessions defined.

Keywords          : snaprintservice kbbuglist
Version           : WINDOWS:3.0,3.0SP1,3.0SP2,4.0
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: February 11, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.