APPC Printing Misinterprets ASCII Data

Last reviewed: February 13, 1998
Article ID: Q180941
The information in this article applies to:
  • Microsoft SNA Server, versions 3.0, 3.0 Service Pack 1 (SP1) 3.0SP2, and 4.0

SYMPTOMS

During printing, the parser prematurely terminates the ASCII Transparent section, and begins to interpret the data as SCS codes. When this occurs, the SNA Print service may log the following event in the Windows NT Application Event Log:

   Event ID: 4101
   Source: PPV5250
   Description: SCS parser has detected a parameter error.

CAUSE

The Closeprinter routine is not setting a pointer to NULL, which may cause calls to open a print session to fail at a later time. This results in Print Server losing track of its position in the datastream, causing some of the data to be misinterpreted as SCS codes instead of transparent data.

STATUS

Microsoft has confirmed this to be a problem in SNA Server versions 3.0, 3.0 SP1, 3.0 SP2, and 4.0. A supported fix is now available for SNA Server versions 3.0 SP2 and 4.0, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Keywords          : kbbug3.00 kbbug3.00.sp1 snaprintservice kbbug3.00.sp2 kbbug4.00 kbprint
Version           : WINDOWS:3.0,3.0SP1,3.0SP2,4.0
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 13, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.