Err Msg: "Missing Component" When Applying Service Pack

Last reviewed: February 17, 1998
Article ID: Q180953
The information in this article applies to:
  • Microsoft SNA Server versions 3.0 Service Pack 1 (SP1) and 3.0 SP2

SYMPTOMS

When you use a non-administrative account to install an SNA Server Service Pack, an error message about a missing component appears at the beginning of the update process. The message does not indicate which component is missing.

CAUSE

The Update program incorrectly reports a missing component error message if the logged on user does not have Admin rights.

WORKAROUND

To work around this problem:

  • Before running the Update program, log on to the system with an account that has administrative privileges.

STATUS

Microsoft has confirmed this to be a problem in SNA Server versions 3.0 SP1 and 3.0 SP2. A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

MORE INFORMATION

With the fix applied, a check examines administrative privileges before running the update. A message appears that states:

   Installing this service pack requires administrative privileges.
Keywords          : kbbug3.00.sp1 snasetup kbbug3.00.sp2 kbsetup
Version           : WINDOWS:3.0SP1,3.0SP2
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: February 17, 1998
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