SNA Server Stops Forwarding FMH-5 Attach Messages

Last reviewed: March 18, 1998
Article ID: Q182574
The information in this article applies to:
  • Microsoft SNA Server, versions 3.0, 3.0 Service Pack 1 (SP1), 3.0 SP2, and 4.0

SYMPTOMS

SNA Server may unexpectedly stop forwarding FMH-5 Attach messages to a specific branch-based SNA Server client computer (where the invokable transaction program [TP] is registered or running). When this occurs, SNA Server reports an Event 60 (DLOAD timeout) in the server's application log. For example:

   Event ID: 60
   Source:   SNA Server
   Description: Failed to invoke APPC TP <tpname>, sense data = 084C0000

084C0000 refers to AP_TRANS_PGM_NOT_AVAIL_NO_RETRY.

On the client computer, the APPC or CPIC invokable TP may never be invoked, or if it is running, the TP's call to CMAPPC or RECEIVE_ALLOCATE will not complete. To recover from this problem, the SnaBase service on the Windows NT client machine must be stopped and restarted.

CAUSE

This problem can occur when the SNA Server client's sponsor connection (LAN session) to the server-side SnaBase service is lost. This problem occurs when the client-end of the client end of the LAN connection fails first.

If the SNA Server client's sponsor fails and reconnects to the SnaBase before SnaBase is notified of the LAN session failure, a timing window exists where the client's invokable TP's are deregistered even though the client has reconnected.

This problem has been observed when an SNA Server Windows NT client is connecting to an SNA Server over TCP/IP sockets, although it may occur with other LAN interfaces.

WORKAROUND

To work around this problem:

  • Determine and correct the cause of the underlying LAN session failure between the SNA Server client and the server.

STATUS

Microsoft has confirmed this to be a problem in SNA Server versions 3.0, 3.0 SP1, 3.0 SP2. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Microsoft has confirmed this to be a problem in SNA Server versions 3.0, 3.0 SP1, 3.0 SP2, and 4.0. A supported fix is now available for SNA Server 3.0 and 4.0, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Keywords          : kbbug3.00 snaappc snabaseservice snacpic snaserverservice snatp snawinnt kbbug3.00.sp2 kbbug4.00
Version           : WINDOWS:3.0,3.0SP1,3.0SP2,4.0
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: March 18, 1998
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