Application Exception in Snaexp.exe After Deleting LUA Pool

Last reviewed: March 19, 1998
Article ID: Q182706
The information in this article applies to:
  • Microsoft SNA Server, versions 3.0, 3.0 SP1, 3.0 SP2, and 4.0

SYMPTOMS

SNA Manager generates an application exception error after the user deletes an LUA pool and then stops the TN3270 service. This behavior can be reproduced using the steps below.

  1. Start SNA Manager with a mainframe connection containing a range of configured LUA LUs.
2. Create an LUA pool and assign the LUs to it. 3. Start the server, activate the connection, and start the TN3270 service. 4. Connect a TN3270 client session. 5. Delete the TN3270 or LUA pool. 6. Delete the LUA LUs from the connection. DO NOT SAVE the configuration
   yet.
7. Stop the TN3270 service.

The following exception messages will appear:

- SnaExp.exe - Application Error

   The instruction at "0x67709190" referenced memory at "0x00000002". The
   memory could not be "read".

   Click "OK"


- SnaExp.exe - Application Error
   The instruction at "0x762b12b6" referenced memory at "0x00000008". The
   memory could not be "read".

CAUSE

SNA Manager does not release the pointer to the LU from the user object.

STATUS

Microsoft has confirmed this to be a problem in SNA Server versions 3.0, 3.0 SP1, and 3.0 SP2. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Microsoft has confirmed this to be a problem in SNA Server version 4.0. A supported fix is now available but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

Keywords          : prodsna snamanager snatn3270
Version           : WINDOWS:3.0,3.0SP1,3.0SP2,4.0
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 19, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.